summaryrefslogtreecommitdiff
path: root/dev-haskell/io-streams
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-20 14:27:17 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-20 14:27:17 +0000
commit5bb9ff1ee56d2b5e75e01a7f066d8b0cec84ec02 (patch)
tree66e860a5099bcad013f1cf667255dc372a7c11b3 /dev-haskell/io-streams
parent7218e1b46bceac05841e90472501742d905fb3fc (diff)
gentoo resync : 20.03.2021
Diffstat (limited to 'dev-haskell/io-streams')
-rw-r--r--dev-haskell/io-streams/Manifest2
-rw-r--r--dev-haskell/io-streams/metadata.xml12
2 files changed, 7 insertions, 7 deletions
diff --git a/dev-haskell/io-streams/Manifest b/dev-haskell/io-streams/Manifest
index dd783fa3fcfc..273c99ceff6f 100644
--- a/dev-haskell/io-streams/Manifest
+++ b/dev-haskell/io-streams/Manifest
@@ -1,3 +1,3 @@
DIST io-streams-1.5.2.0.tar.gz 63812 BLAKE2B a555bc0bc365e4e2c28570da34e6c2891ff56a7460ec8a857285a22ea3a4a2b8975139c3024fd90ffec51386646d9ed632754971abef04fd2c358cba5e0a19c6 SHA512 2cb6c9cded0077f1501b0fba576b79e5ebf21ccc2711a91552ec46ef6d5e943e0c1255cdfda381aa8e4d7691b1e450956bedd2fbd4414b13ef7926b0cc3dc4c3
EBUILD io-streams-1.5.2.0.ebuild 1863 BLAKE2B 7239468f7bb1b4523aadea960743b25ed33bc764e1ec16d167281a7ead27a30553b600bce45d179940dd1f4d4cc47fe2bbbfa73be1bef0ad7a81702a6ee2cef5 SHA512 1e7037f2b0c55ffd1529e89a53bee05b3716511dc7b513e761c8f53ef11b9f50a9c1fc680e23e3b282cf073d8cff80bb38f2715d2533a282a11d985107c5c387
-MISC metadata.xml 2707 BLAKE2B 7f0a861b73b99dd2b03082dc8eb4302491a087a86515ef1fac00e94ceb234bea85359c8cba2bb35895f78e94e68bad896f814a8add92e282faef8000d011af9f SHA512 9b7c8d5124b259fd742c9fbeaf3dee464742a7ab51c48aa00bc09f2795523e37c0d38a204513e5ae3c3ed8addad7b3ad8abcd03f6b1a56f581dff122a572d772
+MISC metadata.xml 2649 BLAKE2B 0c4dacf878753b68f6f3e3d9fc017fe87d0c74739a088a2debd297eb36278d64ae1ad102a0c38de684fcd0fdde970ab3da16119a5fbed3734082043bdecc8367 SHA512 bc24b1ac6d1822c605be4a46768df95d886b2b84f69b34f0cf717945cfe0e5eb70812a96def9e6e701af8decaf54998ad4604816ce630d338ac62d24c70fcdb7
diff --git a/dev-haskell/io-streams/metadata.xml b/dev-haskell/io-streams/metadata.xml
index a86f42647c54..307b43967abb 100644
--- a/dev-haskell/io-streams/metadata.xml
+++ b/dev-haskell/io-streams/metadata.xml
@@ -14,7 +14,7 @@
The io-streams library contains simple and easy-to-use primitives for I/O
using streams. Most users will want to import the top-level convenience
- module &quot;System.IO.Streams&quot;, which re-exports most of the library:
+ module "System.IO.Streams", which re-exports most of the library:
@
import System.IO.Streams (InputStream, OutputStream)
@@ -22,7 +22,7 @@
@
For first-time users, @io-streams@ comes with an included tutorial, which can
- be found in the &quot;System.IO.Streams.Tutorial&quot; module.
+ be found in the "System.IO.Streams.Tutorial" module.
/Features/
@@ -50,19 +50,19 @@
Stream composition leaves the original stream accessible:
@
- ghci&gt; input \&lt;- Streams.fromByteString \&quot;long string\&quot;
+ ghci&gt; input \&lt;- Streams.fromByteString \"long string\"
ghci&gt; wrapped \&lt;- Streams.takeBytes 4 input
ghci&gt; Streams.read wrapped
- Just \&quot;long\&quot;
+ Just \"long\"
ghci&gt; Streams.read wrapped
Nothing
ghci&gt; Streams.read input
- Just \&quot; string\&quot;
+ Just \" string\"
@
Simple types and operations in the IO monad mean straightforward and simple
exception handling and resource cleanup using Haskell standard library
- facilities like &#39;Control.Exception.bracket&#39;.
+ facilities like 'Control.Exception.bracket'.
@io-streams@ comes with: