summaryrefslogtreecommitdiff
path: root/dev-haskell/inspection-testing
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-02 14:09:07 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-02 14:09:07 +0100
commitb17a3ef12038de50228bade1f05502c74e135321 (patch)
tree9026dffec53f92cba48ca9a500a4f778e6304380 /dev-haskell/inspection-testing
parent3cf7c3ef441822c889356fd1812ebf2944a59851 (diff)
gentoo resync : 02.09.2020
Diffstat (limited to 'dev-haskell/inspection-testing')
-rw-r--r--dev-haskell/inspection-testing/Manifest3
-rw-r--r--dev-haskell/inspection-testing/inspection-testing-0.4.2.4.ebuild33
-rw-r--r--dev-haskell/inspection-testing/metadata.xml33
3 files changed, 69 insertions, 0 deletions
diff --git a/dev-haskell/inspection-testing/Manifest b/dev-haskell/inspection-testing/Manifest
new file mode 100644
index 000000000000..185a5adb9f72
--- /dev/null
+++ b/dev-haskell/inspection-testing/Manifest
@@ -0,0 +1,3 @@
+DIST inspection-testing-0.4.2.4.tar.gz 20946 BLAKE2B 20547c5a231083391c886fcef8b3dc153fde8498d9268a297013691a055c65dc93deb31b5988a8cdf1e32d465344802153448850a89b819744551dc13712a1a2 SHA512 16ebfcd20e4ee3a9117670ad9e0d683002262a2f3c52dcfdb7c7123f256db4f133780e759a80469a14c786a4158ef9ba4e7d534e728e8d44188b11765a1e8745
+EBUILD inspection-testing-0.4.2.4.ebuild 788 BLAKE2B 655214cd4f38ac3ff3d34983e4649a94fbe20b09807e784ebffd8ab37cabf59773703c99a1dcb81e3ffbd31cf9b291ef4a024e2e60ff8100458e886e98974e7a SHA512 c94b80a261a0509b5807d88199bd2f3c205a976a77e403cb10daddb7631896434bb4a832945aff92ead2705a89295b7052da565b9804f379f4be2a111003a57d
+MISC metadata.xml 1362 BLAKE2B d0711467f7ad20755b6c997b9091bcf51415a8e214f2e0236d6f469dbef15651581f25ea5f76f0193e0177d7b62d32e6f4d5d0600bf40ff9cda8d1ba017b67f9 SHA512 f8d04337b4963dca5fb5f91b9d769d6a5a03984961cc330b8a460bb6e227ab3810be4aa50a3c2fd2716f7e89ba76ddb819021727581e1f9c98587111778a5edf
diff --git a/dev-haskell/inspection-testing/inspection-testing-0.4.2.4.ebuild b/dev-haskell/inspection-testing/inspection-testing-0.4.2.4.ebuild
new file mode 100644
index 000000000000..92e6cb057df0
--- /dev/null
+++ b/dev-haskell/inspection-testing/inspection-testing-0.4.2.4.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.6.4.9999
+#hackport: flags: -more-tests
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour" # Broken test-suite: compiler-dependent
+inherit haskell-cabal
+
+DESCRIPTION="GHC plugin to do inspection testing"
+HOMEPAGE="https://github.com/nomeata/inspection-testing"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RESTRICT=test # examples/Fusion.hs:22:1: sumUp1 === sumUp2 failed
+
+RDEPEND="dev-haskell/mtl:=[profile?]
+ >=dev-lang/ghc-8.0.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.24.0.0
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=-more-tests
+}
diff --git a/dev-haskell/inspection-testing/metadata.xml b/dev-haskell/inspection-testing/metadata.xml
new file mode 100644
index 000000000000..f4d3257dab77
--- /dev/null
+++ b/dev-haskell/inspection-testing/metadata.xml
@@ -0,0 +1,33 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>haskell@gentoo.org</email>
+ <name>Gentoo Haskell</name>
+ </maintainer>
+ <longdescription>
+ Some carefully crafted libraries make promises to their
+ users beyond functionality and performance.
+
+ Examples are: Fusion libraries promise intermediate data
+ structures to be eliminated. Generic programming libraries promise
+ that the generic implementation is identical to the
+ hand-written one. Some libraries may promise allocation-free
+ or branch-free code.
+
+ Conventionally, the modus operandi in all these cases is
+ that the library author manually inspects the (intermediate or
+ final) code produced by the compiler. This is not only
+ tedious, but makes it very likely that some change, either
+ in the library itself or the surrounding eco-system,
+ breaks the library's promised without anyone noticing.
+
+ This package provides a disciplined way of specifying such
+ properties, and have them checked by the compiler. This way,
+ this checking can be part of the ususal development cycle
+ and regressions caught early.
+
+ See the documentation in &quot;Test.Inspection&quot; or the project
+ webpage for more examples and more information.
+ </longdescription>
+</pkgmetadata>