summaryrefslogtreecommitdiff
path: root/dev-haskell/httpd-shed/httpd-shed-0.4.1.1-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-30 09:09:34 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-30 09:09:34 +0100
commitad0412d0cafb8c04ce98024155cf99a4cc27db44 (patch)
treec34688ab389c18775a322de6cd4cfd957cbe8014 /dev-haskell/httpd-shed/httpd-shed-0.4.1.1-r1.ebuild
parentcdb747b791914a30c287a3a8e33d1b635e431707 (diff)
gentoo auto-resync : 30:07:2022 - 09:09:33
Diffstat (limited to 'dev-haskell/httpd-shed/httpd-shed-0.4.1.1-r1.ebuild')
-rw-r--r--dev-haskell/httpd-shed/httpd-shed-0.4.1.1-r1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-haskell/httpd-shed/httpd-shed-0.4.1.1-r1.ebuild b/dev-haskell/httpd-shed/httpd-shed-0.4.1.1-r1.ebuild
new file mode 100644
index 000000000000..25e4e5f39a23
--- /dev/null
+++ b/dev-haskell/httpd-shed/httpd-shed-0.4.1.1-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.6.1.9999
+#hackport: flags: +network-uri,+network-bsd
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="A simple web-server with an interact style API"
+HOMEPAGE="https://hackage.haskell.org/package/httpd-shed"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+IUSE="buildexamples"
+
+RDEPEND=">=dev-lang/ghc-7.4.1:=
+ >=dev-haskell/network-2.3:=[profile?] <dev-haskell/network-3.2:=[profile?]
+ >=dev-haskell/network-bsd-2.7:=[profile?] <dev-haskell/network-bsd-2.9:=[profile?]
+ >=dev-haskell/network-uri-2.6:=[profile?]
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag buildexamples buildexamples) \
+ --flag=network-bsd \
+ --flag=network-uri
+}