summaryrefslogtreecommitdiff
path: root/dev-haskell/http2/http2-1.6.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-haskell/http2/http2-1.6.2.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-haskell/http2/http2-1.6.2.ebuild')
-rw-r--r--dev-haskell/http2/http2-1.6.2.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/dev-haskell/http2/http2-1.6.2.ebuild b/dev-haskell/http2/http2-1.6.2.ebuild
new file mode 100644
index 000000000000..24d8f5492916
--- /dev/null
+++ b/dev-haskell/http2/http2-1.6.2.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+# ebuild generated by hackport 0.4.7.9999
+#hackport: flags: -devel
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="HTTP/2.0 library including frames and HPACK"
+HOMEPAGE="http://hackage.haskell.org/package/http2"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-haskell/bytestring-builder:=[profile?]
+ dev-haskell/case-insensitive:=[profile?]
+ dev-haskell/psqueues:=[profile?]
+ dev-haskell/stm:=[profile?]
+ >=dev-lang/ghc-7.6.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.16.0
+ test? ( dev-haskell/aeson
+ dev-haskell/aeson-pretty
+ >=dev-haskell/doctest-0.9.3
+ dev-haskell/glob
+ dev-haskell/hex
+ >=dev-haskell/hspec-1.3
+ dev-haskell/text
+ dev-haskell/unordered-containers
+ dev-haskell/vector
+ dev-haskell/word8 )
+"
+
+src_prepare() {
+ # workaround Cabal bug at picking unused deps
+ eapply "${FILESDIR}"/${PN}-1.6.0-less-deps.patch
+ eapply "${FILESDIR}"/${PN}-1.6.0-even-less-deps.patch
+ eapply_user
+}
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=-devel
+}