summaryrefslogtreecommitdiff
path: root/dev-haskell/http/http-4000.2.22.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-haskell/http/http-4000.2.22.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-haskell/http/http-4000.2.22.ebuild')
-rw-r--r--dev-haskell/http/http-4000.2.22.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/dev-haskell/http/http-4000.2.22.ebuild b/dev-haskell/http/http-4000.2.22.ebuild
new file mode 100644
index 000000000000..1c867514970b
--- /dev/null
+++ b/dev-haskell/http/http-4000.2.22.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.6.9999
+#hackport: flags: -warp-tests,-mtl1,-warn-as-error,-old-base,-network23
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+MY_PN="HTTP"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="A library for client-side HTTP"
+HOMEPAGE="https://github.com/haskell/HTTP"
+SRC_URI="mirror://hackage/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="conduit10 +network-uri"
+
+RDEPEND=">=dev-haskell/mtl-2.0:=[profile?] <dev-haskell/mtl-2.3:=[profile?]
+ >=dev-haskell/old-time-1.0.0.0:=[profile?] <dev-haskell/old-time-1.2:=[profile?]
+ >=dev-haskell/parsec-2.0:=[profile?] <dev-haskell/parsec-3.2:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+ network-uri? ( >=dev-haskell/network-2.6:=[profile?] <dev-haskell/network-2.7:=[profile?]
+ >=dev-haskell/network-uri-2.6:=[profile?] <dev-haskell/network-uri-2.7:=[profile?] )
+ !network-uri? ( >=dev-haskell/network-2.2.1.8:=[profile?] <dev-haskell/network-2.6:=[profile?] )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ dev-lang/ghc
+ test? ( >=dev-haskell/httpd-shed-0.4 <dev-haskell/httpd-shed-0.5
+ >=dev-haskell/hunit-1.2.0.1 <dev-haskell/hunit-1.4
+ >=dev-haskell/puremd5-0.2.4 <dev-haskell/puremd5-2.2
+ >=dev-haskell/split-0.1.3 <dev-haskell/split-0.3
+ >=dev-haskell/test-framework-0.2.0 <dev-haskell/test-framework-0.9
+ >=dev-haskell/test-framework-hunit-0.3.0 <dev-haskell/test-framework-hunit-0.4 )
+"
+
+S="${WORKDIR}/${MY_P}"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag conduit10 conduit10) \
+ --flag=-mtl1 \
+ $(cabal_flag network-uri network-uri) \
+ --flag=-network23 \
+ --flag=-old-base \
+ --flag=-warn-as-error \
+ --flag=-warp-tests
+}