summaryrefslogtreecommitdiff
path: root/dev-haskell/hpack
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-haskell/hpack
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-haskell/hpack')
-rw-r--r--dev-haskell/hpack/Manifest4
-rw-r--r--dev-haskell/hpack/files/hpack-0.14.1-aeson-1.patch24
-rw-r--r--dev-haskell/hpack/hpack-0.14.1.ebuild39
-rw-r--r--dev-haskell/hpack/metadata.xml11
4 files changed, 78 insertions, 0 deletions
diff --git a/dev-haskell/hpack/Manifest b/dev-haskell/hpack/Manifest
new file mode 100644
index 000000000000..8996e2bc736f
--- /dev/null
+++ b/dev-haskell/hpack/Manifest
@@ -0,0 +1,4 @@
+AUX hpack-0.14.1-aeson-1.patch 1088 BLAKE2B fbdac681ca35879fe0cf789cf8f4f8b459e3900a6b56bedb48afd8fef7b6cc890341c5649da8127752a4131402d8e67f50c3722ce9ba41cbd5a97f4976809d76 SHA512 ac178c92f2dbd1e0b498b82363b5c03525597c2f3d0fe834f9e7b6e80312e6adae773861b6c18768cd45c2ea323b10ea65b8e5f2991cd3678e9966d9fd876172
+DIST hpack-0.14.1.tar.gz 38373 BLAKE2B d5c3b900e3e2fd852081934f4a7b4a327f4647608ceecf76ac65faf4e464bed7428e4b444f7b06f8a0e7661458e1817aedaaa2ea2dd8161a362be9f596f7f0be SHA512 5bd7b5335aef1a3d866c07937e457397c82235c99b578b6270b699895b9a5d39259eef324e6741af9a6e296bfe56587fc9888dc0fc2e4bd6fe99bbc74a7e0b04
+EBUILD hpack-0.14.1.ebuild 1034 BLAKE2B 9d64e89ecd9196402c1fe91a33065d47fada4bd494a2941a16ef088f5c850eebfb37ca4858c14bb6a682706eaebe90e0813ba84411f5f61c89a996320b454aee SHA512 bb59bedb19029098e7dc2759f22cc1b587f9fd868c6edc7f99817301e606af0482fafee4694f80315dbdd98438c30503b548716c60da17966ec1d472fe09d49b
+MISC metadata.xml 333 BLAKE2B e31588ab4845a712814c6d194bcf1d2b4600011055f83c672ee183f2f8bfdc4d8da339027953a59aabf0765c683a1aaf92f3dcfb8eb6899f2b77c2df856f08e4 SHA512 0de08ff54a63322f19c4b560d10130fe7d78ff9c4880fdac2da4d5ebcdeb1fe3800e8910b60319e4218c8cc9ac547fa4b01885f8a21078da2f4c80e6e84b405b
diff --git a/dev-haskell/hpack/files/hpack-0.14.1-aeson-1.patch b/dev-haskell/hpack/files/hpack-0.14.1-aeson-1.patch
new file mode 100644
index 000000000000..a4b3fd1f4b6a
--- /dev/null
+++ b/dev-haskell/hpack/files/hpack-0.14.1-aeson-1.patch
@@ -0,0 +1,24 @@
+diff --git a/src/Hpack/Config.hs b/src/Hpack/Config.hs
+index cb84f71..5566b8c 100644
+--- a/src/Hpack/Config.hs
++++ b/src/Hpack/Config.hs
+@@ -101,3 +101,9 @@ githubBaseUrl = "https://github.com/"
+
+-genericParseJSON_ :: forall a. (Generic a, GFromJSON (Rep a), HasTypeName a) => Value -> Parser a
++#if MIN_VERSION_aeson(1,0,0)
++# define AESON_ARITY Zero
++#else
++# define AESON_ARITY
++#endif
++
++genericParseJSON_ :: forall a. (Generic a, GFromJSON AESON_ARITY (Rep a), HasTypeName a) => Value -> Parser a
+ genericParseJSON_ = genericParseJSON defaultOptions {fieldLabelModifier = hyphenize name}
+diff --git a/test/Hpack/ConfigSpec.hs b/test/Hpack/ConfigSpec.hs
+index 320ba9a..d13d932 100644
+--- a/test/Hpack/ConfigSpec.hs
++++ b/test/Hpack/ConfigSpec.hs
+@@ -971,3 +971,3 @@ spec = do
+ |]
+- readPackageConfig file `shouldReturn` Left (file ++ ": Error in $.executables.foo: failed to parse field executables: The key \"main\" was not found")
++ readPackageConfig file `shouldReturn` Left (file ++ ": Error in $.executables.foo: key \"main\" not present")
+
diff --git a/dev-haskell/hpack/hpack-0.14.1.ebuild b/dev-haskell/hpack/hpack-0.14.1.ebuild
new file mode 100644
index 000000000000..7ae2c30ef742
--- /dev/null
+++ b/dev-haskell/hpack/hpack-0.14.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+# ebuild generated by hackport 0.5.9999
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="An alternative format for Haskell packages"
+HOMEPAGE="https://github.com/sol/hpack#readme"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/aeson-0.8:=[profile?]
+ >=dev-haskell/base-compat-0.8:=[profile?]
+ dev-haskell/glob:=[profile?]
+ dev-haskell/text:=[profile?]
+ dev-haskell/unordered-containers:=[profile?]
+ dev-haskell/yaml:=[profile?]
+ >=dev-lang/ghc-7.8.2:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.18.1.3
+ test? ( >=dev-haskell/aeson-0.10
+ dev-haskell/aeson-qq
+ >=dev-haskell/hspec-2 <dev-haskell/hspec-3
+ dev-haskell/interpolate
+ >=dev-haskell/mockery-0.3
+ dev-haskell/quickcheck
+ dev-haskell/temporary )
+"
+
+PATCHES=("${FILESDIR}"/${P}-aeson-1.patch)
diff --git a/dev-haskell/hpack/metadata.xml b/dev-haskell/hpack/metadata.xml
new file mode 100644
index 000000000000..acec350af770
--- /dev/null
+++ b/dev-haskell/hpack/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>haskell@gentoo.org</email>
+ <name>Gentoo Haskell</name>
+ </maintainer>
+ <longdescription>
+ An alternative format for Haskell packages
+ </longdescription>
+</pkgmetadata>