summaryrefslogtreecommitdiff
path: root/dev-haskell/hpack/hpack-0.14.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-haskell/hpack/hpack-0.14.1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-haskell/hpack/hpack-0.14.1.ebuild')
-rw-r--r--dev-haskell/hpack/hpack-0.14.1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-haskell/hpack/hpack-0.14.1.ebuild b/dev-haskell/hpack/hpack-0.14.1.ebuild
new file mode 100644
index 000000000000..7ae2c30ef742
--- /dev/null
+++ b/dev-haskell/hpack/hpack-0.14.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+# ebuild generated by hackport 0.5.9999
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="An alternative format for Haskell packages"
+HOMEPAGE="https://github.com/sol/hpack#readme"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/aeson-0.8:=[profile?]
+ >=dev-haskell/base-compat-0.8:=[profile?]
+ dev-haskell/glob:=[profile?]
+ dev-haskell/text:=[profile?]
+ dev-haskell/unordered-containers:=[profile?]
+ dev-haskell/yaml:=[profile?]
+ >=dev-lang/ghc-7.8.2:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.18.1.3
+ test? ( >=dev-haskell/aeson-0.10
+ dev-haskell/aeson-qq
+ >=dev-haskell/hspec-2 <dev-haskell/hspec-3
+ dev-haskell/interpolate
+ >=dev-haskell/mockery-0.3
+ dev-haskell/quickcheck
+ dev-haskell/temporary )
+"
+
+PATCHES=("${FILESDIR}"/${P}-aeson-1.patch)