summaryrefslogtreecommitdiff
path: root/dev-haskell/hit
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-haskell/hit
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-haskell/hit')
-rw-r--r--dev-haskell/hit/Manifest3
-rw-r--r--dev-haskell/hit/hit-0.6.3.ebuild50
-rw-r--r--dev-haskell/hit/metadata.xml20
3 files changed, 73 insertions, 0 deletions
diff --git a/dev-haskell/hit/Manifest b/dev-haskell/hit/Manifest
new file mode 100644
index 000000000000..bcef7fac466a
--- /dev/null
+++ b/dev-haskell/hit/Manifest
@@ -0,0 +1,3 @@
+DIST hit-0.6.3.tar.gz 38690 BLAKE2B 928a532cacb2393b46b9e5abeee6d66bf140e9e4a71f359b8a35016f97db4eeb32f4efb6c56d74528d3311ae4d6477716670c14ae6ad7361a7892575185dd336 SHA512 82ccfeb77a439caa1792f1ae29535636764be9e6e94f75973f37a86db6627a492e57da835954384ef8468799de9f0897e20905f65dad256fe3547a4248d5fffc
+EBUILD hit-0.6.3.ebuild 1450 BLAKE2B 76458303cac6d86593d06f05ffe3e479f88c0349081d175a72fde6d4a83e12ea138e26e75a33e8cc376d1471b4257eeaa83e6bd046bc1334e316d508baac541c SHA512 973a7050384748b2a93234be69c0bd1838a93c0d43fd5e3c9226974b7e0dd75c613df53c3cf24a7218676524d2fc29042e574d8216dddec5ad911d4566ef458e
+MISC metadata.xml 717 BLAKE2B c3c7f87958186af89f91d209015050b8adf88a9da76dbcb4e64f2132d4eca3f209b8c97873af77cc98d5d3a605cf13eb8edb1261ed4b80086c8aa6774e1c5ea4 SHA512 64247968400adb4b29dc6de54ecada645f2c7365c9ca111e8639f803a416a6865ad783f19d73a0a70b35be9bc900d0d5fb346e657b85f18ffb37c482ecc74c77
diff --git a/dev-haskell/hit/hit-0.6.3.ebuild b/dev-haskell/hit/hit-0.6.3.ebuild
new file mode 100644
index 000000000000..466101757343
--- /dev/null
+++ b/dev-haskell/hit/hit-0.6.3.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+# ebuild generated by hackport 0.5.3.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Git operations in haskell"
+HOMEPAGE="https://github.com/vincenthz/hit"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug executable"
+
+RDEPEND=">=dev-haskell/attoparsec-0.10.1:=[profile?]
+ dev-haskell/byteable:=[profile?]
+ dev-haskell/cryptohash:=[profile?]
+ >=dev-haskell/hourglass-0.2:=[profile?]
+ dev-haskell/mtl:=[profile?]
+ >=dev-haskell/parsec-3:=[profile?]
+ dev-haskell/patience:=[profile?]
+ dev-haskell/random:=[profile?]
+ dev-haskell/system-fileio:=[profile?]
+ dev-haskell/system-filepath:=[profile?]
+ dev-haskell/unix-compat:=[profile?]
+ dev-haskell/utf8-string:=[profile?]
+ dev-haskell/vector:=[profile?]
+ dev-haskell/zlib:=[profile?]
+ >=dev-haskell/zlib-bindings-0.1:=[profile?] <dev-haskell/zlib-bindings-0.2:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+ executable? ( >=dev-haskell/hashable-1.2:=[profile?]
+ dev-haskell/hashtables:=[profile?] )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( >=dev-haskell/bytedump-1.0
+ dev-haskell/tasty
+ dev-haskell/tasty-quickcheck )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag debug debug) \
+ $(cabal_flag executable executable)
+}
diff --git a/dev-haskell/hit/metadata.xml b/dev-haskell/hit/metadata.xml
new file mode 100644
index 000000000000..aeb520f51526
--- /dev/null
+++ b/dev-haskell/hit/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>haskell@gentoo.org</email>
+ <name>Gentoo Haskell</name>
+ </maintainer>
+ <longdescription>
+ An haskell implementation of git storage operations, allowing users
+ to manipulate git repositories (read and write).
+
+ This implementation is fully interoperable with the main C implementation.
+
+ This is stricly only manipulating the git store (what's inside the .git directory),
+ and doesn't do anything with the index or your working directory files.
+ </longdescription>
+ <use>
+ <flag name="executable">Build the executable</flag>
+ </use>
+</pkgmetadata>