summaryrefslogtreecommitdiff
path: root/dev-haskell/hit
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-haskell/hit
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-haskell/hit')
-rw-r--r--dev-haskell/hit/Manifest3
-rw-r--r--dev-haskell/hit/hit-0.6.3.ebuild50
-rw-r--r--dev-haskell/hit/metadata.xml22
3 files changed, 75 insertions, 0 deletions
diff --git a/dev-haskell/hit/Manifest b/dev-haskell/hit/Manifest
new file mode 100644
index 000000000000..7c85d7824e93
--- /dev/null
+++ b/dev-haskell/hit/Manifest
@@ -0,0 +1,3 @@
+DIST hit-0.6.3.tar.gz 38690 SHA256 db86b3712029a4e40d1306dd6cc9ca2c9f4c77fe65a2b74106f1cbd2de26e471 SHA512 82ccfeb77a439caa1792f1ae29535636764be9e6e94f75973f37a86db6627a492e57da835954384ef8468799de9f0897e20905f65dad256fe3547a4248d5fffc WHIRLPOOL e90e0d842666b027be5c3996a233e66385c9cb62d694a8dd923ca20cfadeedabc892dc25c5a6367310cf9d3892e731563234fe49330e48cd1a46346095388c0c
+EBUILD hit-0.6.3.ebuild 1450 SHA256 6881f877d8e88a2a882f60bf6c4978e22be6f31830566ec894d8838ea3e72731 SHA512 973a7050384748b2a93234be69c0bd1838a93c0d43fd5e3c9226974b7e0dd75c613df53c3cf24a7218676524d2fc29042e574d8216dddec5ad911d4566ef458e WHIRLPOOL 4e822be34683de595cbbc5eaa31e8105658f4527229aef851993e7e1a23cff8ed97b14e118deb994956ec113b3611f14f0527cfc2aa1a46d7b9f6ad85050eda9
+MISC metadata.xml 736 SHA256 30eeb6dd40a61daef4da529716f0399e4c30ef5ec5691e5c86886580cc66307c SHA512 a40e10deb4814f516a4810164360d118d04825ca4cf5dbed5eb909b91f156199e4033008d8448a8740c44ff77d74a46d32a930f705735b1781d72130da71dfd7 WHIRLPOOL ddeffc201723b7d35e28c3da381536275310ab2fd9b10944b8e88e5e6d0a0ab2c08097ec328d4645b44c960831e3f964384066131e3a2cce68c710a75c2c0d8b
diff --git a/dev-haskell/hit/hit-0.6.3.ebuild b/dev-haskell/hit/hit-0.6.3.ebuild
new file mode 100644
index 000000000000..466101757343
--- /dev/null
+++ b/dev-haskell/hit/hit-0.6.3.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+# ebuild generated by hackport 0.5.3.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Git operations in haskell"
+HOMEPAGE="https://github.com/vincenthz/hit"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug executable"
+
+RDEPEND=">=dev-haskell/attoparsec-0.10.1:=[profile?]
+ dev-haskell/byteable:=[profile?]
+ dev-haskell/cryptohash:=[profile?]
+ >=dev-haskell/hourglass-0.2:=[profile?]
+ dev-haskell/mtl:=[profile?]
+ >=dev-haskell/parsec-3:=[profile?]
+ dev-haskell/patience:=[profile?]
+ dev-haskell/random:=[profile?]
+ dev-haskell/system-fileio:=[profile?]
+ dev-haskell/system-filepath:=[profile?]
+ dev-haskell/unix-compat:=[profile?]
+ dev-haskell/utf8-string:=[profile?]
+ dev-haskell/vector:=[profile?]
+ dev-haskell/zlib:=[profile?]
+ >=dev-haskell/zlib-bindings-0.1:=[profile?] <dev-haskell/zlib-bindings-0.2:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+ executable? ( >=dev-haskell/hashable-1.2:=[profile?]
+ dev-haskell/hashtables:=[profile?] )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( >=dev-haskell/bytedump-1.0
+ dev-haskell/tasty
+ dev-haskell/tasty-quickcheck )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag debug debug) \
+ $(cabal_flag executable executable)
+}
diff --git a/dev-haskell/hit/metadata.xml b/dev-haskell/hit/metadata.xml
new file mode 100644
index 000000000000..3f0d2b779d97
--- /dev/null
+++ b/dev-haskell/hit/metadata.xml
@@ -0,0 +1,22 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>haskell@gentoo.org</email>
+ <name>Gentoo Haskell</name>
+ </maintainer>
+ <longdescription>
+
+ An haskell implementation of git storage operations, allowing users
+ to manipulate git repositories (read and write).
+
+ This implementation is fully interoperable with the main C implementation.
+
+ This is stricly only manipulating the git store (what's inside the .git directory),
+ and doesn't do anything with the index or your working directory files.
+
+ </longdescription>
+ <use>
+ <flag name="executable">Build the executable</flag>
+ </use>
+</pkgmetadata>