summaryrefslogtreecommitdiff
path: root/dev-haskell/hdbc-odbc
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-haskell/hdbc-odbc
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-haskell/hdbc-odbc')
-rw-r--r--dev-haskell/hdbc-odbc/Manifest6
-rw-r--r--dev-haskell/hdbc-odbc/files/hdbc-odbc-2.3.1.0-ghc-7.6.patch52
-rw-r--r--dev-haskell/hdbc-odbc/hdbc-odbc-2.3.1.1.ebuild65
-rw-r--r--dev-haskell/hdbc-odbc/hdbc-odbc-2.4.0.1.ebuild64
-rw-r--r--dev-haskell/hdbc-odbc/metadata.xml20
5 files changed, 207 insertions, 0 deletions
diff --git a/dev-haskell/hdbc-odbc/Manifest b/dev-haskell/hdbc-odbc/Manifest
new file mode 100644
index 000000000000..98b962b23473
--- /dev/null
+++ b/dev-haskell/hdbc-odbc/Manifest
@@ -0,0 +1,6 @@
+AUX hdbc-odbc-2.3.1.0-ghc-7.6.patch 1773 BLAKE2B df997ccc0b3bf454df09377c7a53fa407aa816a46da27a1766af89659333377b420fa26aa7a0cf666c1b617cda7d3a8642e58a541043f50811955589e251e643 SHA512 1978f79956a73b8615331698839583a242bf15987875a43df496b3bc68a814e516cd3d6868cad47b2b3f30226295a8affeab9995c056f58b649eb6a673ffb034
+DIST HDBC-odbc-2.3.1.1.tar.gz 24518 BLAKE2B 306c9af823e55c56ad61f46ac44c4b055e725f0f9400998938a1c00d7d0a330bb06f581c15990bab4c60293e323464cd140b6ff14ebd80d35fe6b92d10890ff5 SHA512 dbf95afca7906c4814f79e00d1fef0d26ed71c8da45a0fd51c4e3e4e0427d56d1937be0b0c4088841d5f12d93da0c4c29ec6f359c2e58fdf4c693f34bdae250a
+DIST HDBC-odbc-2.4.0.1.tar.gz 27185 BLAKE2B 5ccd40f9dcc3ee7045f8719b16f0d65f049cd52c323b86aebdc11fba7c9003747f29850aec059d4d092826c579e0f9dc2f9d12dbbf7b1e261ca052a3e5ba122a SHA512 ae9f5ac2aa6adfc155999fb78b35a12e381d1589bf2539306a4e346af4eee401db8af8ef74348cc0707620f9586367701505d0d61bd96f00f0ebeb9240ed9a06
+EBUILD hdbc-odbc-2.3.1.1.ebuild 1467 BLAKE2B 9a9900c30a9d8944c2665975a95818e1b9ff0b1a5bbcb6cfee6ba92a3ae080e85f21fba4ba5bcaabd371a716b27c8efde02591e53665921130d44cbbee56c807 SHA512 4ae7b7fcc5c64bb742d299ac58509918b675e95cfd4136d1a72f58c7c947f0dcc8256758f1e914c88e997839a7ce68230f62b2fc2df9018d1b5bc518f59d8558
+EBUILD hdbc-odbc-2.4.0.1.ebuild 1611 BLAKE2B dabffc858dbe9174e02d88144fa6df1405725345ccd6e18aa8deb4f22f0c40ff011600a2089f4c6baff7985462224a940812d85a66c252fa816009207d3db4d5 SHA512 dce4e392e6cf4357fdd1f8d670a322cd7ebc24e784a95590cff45a6b4fabed8676fb98530503973c07df517774877719c234ba7dd4bf9c8e6ae01f6fd49ccdb1
+MISC metadata.xml 677 BLAKE2B 4bba37b7b13610bbf5d540b8a9d972d3338309aeaa3606f69d3dbf1411015a1d9907c0958a053ca13449002001e53de2669bc90e2331d389e20002ab324e3251 SHA512 bf7a8f735c7cbfd829bbca02e919e17ffe388d8b18289ea8126645588f856594e55f5891f924f19072e6a270d711b2397eab40c32d05d98eec27d69f20467170
diff --git a/dev-haskell/hdbc-odbc/files/hdbc-odbc-2.3.1.0-ghc-7.6.patch b/dev-haskell/hdbc-odbc/files/hdbc-odbc-2.3.1.0-ghc-7.6.patch
new file mode 100644
index 000000000000..8092cf16da6c
--- /dev/null
+++ b/dev-haskell/hdbc-odbc/files/hdbc-odbc-2.3.1.0-ghc-7.6.patch
@@ -0,0 +1,52 @@
+--- HDBC-odbc-2.3.1.0-orig/testsrc/TestSbasics.hs 2011-08-10 07:16:38.000000000 +1000
++++ HDBC-odbc-2.3.1.0/testsrc/TestSbasics.hs 2012-10-13 12:30:47.216363898 +1100
+@@ -1,9 +1,13 @@
++{-# LANGUAGE CPP, ScopedTypeVariables #-}
+ module TestSbasics(tests) where
+ import Test.HUnit
+ import Database.HDBC
+ import TestUtils
+ import System.IO
+-import Control.Exception hiding (catch)
++#if !MIN_VERSION_base(4,6,0)
++import Prelude hiding (catch)
++#endif
++import Control.Exception
+
+ openClosedb = sqlTestCase $
+ do dbh <- connectDB
+@@ -123,7 +127,7 @@
+ -- Let's try a rollback.
+ catch (withTransaction dbh (\_ -> do sExecuteMany sth rows
+ fail "Foo"))
+- (\_ -> return ())
++ (\(_::IOException) -> return ())
+ sExecute qrysth []
+ sFetchAllRows qrysth >>= (assertEqual "rollback" [[Just "0"]])
+
+--- HDBC-odbc-2.3.1.0-orig/testsrc/Testbasics.hs 2011-08-10 07:16:38.000000000 +1000
++++ HDBC-odbc-2.3.1.0/testsrc/Testbasics.hs 2012-10-13 12:30:10.883415738 +1100
+@@ -1,9 +1,13 @@
++{-# LANGUAGE CPP, ScopedTypeVariables #-}
+ module Testbasics(tests) where
+ import Test.HUnit
+ import Database.HDBC
+ import TestUtils
+ import System.IO
+-import Control.Exception hiding (catch)
++#if !MIN_VERSION_base(4,6,0)
++import Prelude hiding (catch)
++#endif
++import Control.Exception
+
+ openClosedb = sqlTestCase $
+ do dbh <- connectDB
+@@ -140,7 +144,7 @@
+ -- Let's try a rollback.
+ catch (withTransaction dbh (\_ -> do executeMany sth rows
+ fail "Foo"))
+- (\_ -> return ())
++ (\(_::IOException) -> return ())
+ execute qrysth []
+ fetchAllRows qrysth >>= (assertEqual "rollback" [[SqlString "0"]])
+
diff --git a/dev-haskell/hdbc-odbc/hdbc-odbc-2.3.1.1.ebuild b/dev-haskell/hdbc-odbc/hdbc-odbc-2.3.1.1.ebuild
new file mode 100644
index 000000000000..cd66bbb26ccd
--- /dev/null
+++ b/dev-haskell/hdbc-odbc/hdbc-odbc-2.3.1.1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.1.9999
+
+# haddock is disabled as it chokes in .hsc file:
+# Database/HDBC/ODBC/Statement.hsc:462:3:
+# parse error on input `Word16'
+CABAL_FEATURES="bin lib profile hoogle hscolour"
+inherit haskell-cabal
+
+MY_PN="HDBC-odbc"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="ODBC driver for HDBC"
+HOMEPAGE="https://github.com/hdbc/hdbc-odbc"
+SRC_URI="mirror://hackage/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="2/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="test" # requires configured ODBC
+
+RDEPEND=">=dev-haskell/hdbc-2.1.0:=[profile?]
+ dev-haskell/mtl:=[profile?]
+ dev-haskell/utf8-string:=[profile?]
+ >=dev-lang/ghc-7.0.1:=
+ >=dev-db/unixODBC-2.2
+ "
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6
+ test? ( dev-haskell/convertible
+ dev-haskell/hunit
+ dev-haskell/quickcheck
+ dev-haskell/testpack
+ )
+ "
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-2.3.1.0-ghc-7.6.patch"
+}
+
+src_configure() {
+ cabal_src_configure $(cabal_flag test buildtests)
+}
+
+src_test() {
+ # default tests
+ haskell-cabal_src_test || die "cabal test failed"
+
+ # built custom tests
+ "${S}/dist/build/runtests/runtests" || die "unit tests failed"
+}
+
+src_install() {
+ cabal_src_install
+
+ # if tests were enabled, make sure the unit test driver is deleted
+ rm -f "${ED}/usr/bin/runtests"
+}
diff --git a/dev-haskell/hdbc-odbc/hdbc-odbc-2.4.0.1.ebuild b/dev-haskell/hdbc-odbc/hdbc-odbc-2.4.0.1.ebuild
new file mode 100644
index 000000000000..dd50a5bc197f
--- /dev/null
+++ b/dev-haskell/hdbc-odbc/hdbc-odbc-2.4.0.1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.4.9999
+
+# haddock is disabled as it chokes in .hsc file:
+# Database/HDBC/ODBC/Statement.hsc:462:3:
+# parse error on input `Word16'
+CABAL_FEATURES="bin lib profile hoogle hscolour"
+inherit haskell-cabal
+
+MY_PN="HDBC-odbc"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="ODBC driver for HDBC"
+HOMEPAGE="https://github.com/hdbc/hdbc-odbc"
+SRC_URI="mirror://hackage/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="2/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="buildstresstest test"
+RESTRICT="test" # requires configured ODBC
+
+RDEPEND=">=dev-haskell/hdbc-2.1.0:2=[profile?]
+ dev-haskell/mtl:=[profile?]
+ dev-haskell/utf8-string:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+ >=dev-db/unixODBC-2.2
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ buildstresstest? ( dev-haskell/random:=[profile?]
+ dev-haskell/resource-pool:=[profile?] )
+ test? ( dev-haskell/convertible:=[profile?]
+ dev-haskell/hunit:=[profile?]
+ dev-haskell/quickcheck:2=[profile?]
+ dev-haskell/testpack:=[profile?] )
+"
+
+S="${WORKDIR}/${MY_P}"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag buildstresstest buildstresstest) \
+ $(cabal_flag test buildtests)
+}
+
+src_test() {
+ # default tests
+ haskell-cabal_src_test || die "cabal test failed"
+
+ # built custom tests
+ "${S}/dist/build/runtests/runtests" || die "unit tests failed"
+}
+
+src_install() {
+ cabal_src_install
+
+ # if tests were enabled, make sure the unit test driver is deleted
+ rm -f "${ED}/usr/bin/runtests"
+}
diff --git a/dev-haskell/hdbc-odbc/metadata.xml b/dev-haskell/hdbc-odbc/metadata.xml
new file mode 100644
index 000000000000..5c72d4a3ad3d
--- /dev/null
+++ b/dev-haskell/hdbc-odbc/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>haskell@gentoo.org</email>
+ <name>Gentoo Haskell</name>
+ </maintainer>
+ <longdescription>
+ This package provides an ODBC database backend for HDBC.
+ It is cross-platform and supports unixODBC on Unix/Linux/POSIX platforms
+ and Microsoft ODBC on Windows. It is also the preferred way to access
+ MySQL databases from Haskell.
+ </longdescription>
+ <use>
+ <flag name="buildstresstest">Build stress test</flag>
+ </use>
+ <upstream>
+ <remote-id type="github">hdbc/hdbc-odbc</remote-id>
+ </upstream>
+</pkgmetadata>