summaryrefslogtreecommitdiff
path: root/dev-haskell/hashable
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-haskell/hashable
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-haskell/hashable')
-rw-r--r--dev-haskell/hashable/Manifest5
-rw-r--r--dev-haskell/hashable/hashable-1.2.1.0.ebuild42
-rw-r--r--dev-haskell/hashable/hashable-1.2.4.0.ebuild38
-rw-r--r--dev-haskell/hashable/metadata.xml18
4 files changed, 103 insertions, 0 deletions
diff --git a/dev-haskell/hashable/Manifest b/dev-haskell/hashable/Manifest
new file mode 100644
index 000000000000..e9c6674b1872
--- /dev/null
+++ b/dev-haskell/hashable/Manifest
@@ -0,0 +1,5 @@
+DIST hashable-1.2.1.0.tar.gz 22389 BLAKE2B 62b883954ad22e25ace7b267e79e2a62be35671dc14d04c9ad12675d9a350b829088bb3c79b254cbd4783953ff46543f68d71e002b96cb1ba272ec808b17eaaa SHA512 343f6b9eb40d089f0f2187427af7d7b5dbe15884649ddc8e0b140db129f21fc44f6bf41a262a3b2a0c74d967be6f603799472802d835e48a442f836dd8142607
+DIST hashable-1.2.4.0.tar.gz 24491 BLAKE2B c5d3fb061a2e4fbb7c85f00c24818e708d8511c547588eea024240611d427f982633cacecd35d9a8f4306377ef0b5f75889271cd6bbeabfd0d1f837cb3b4b8db SHA512 992027ce617e347414e328e05afe69b8621fb1af21fef58836761d2002a1f9f7f97c981ff3c4fe8699a1da124771df575717ed4e3fd0bbe5c62d81be1322dbf6
+EBUILD hashable-1.2.1.0.ebuild 1153 BLAKE2B 1d11b8d60aecf111b015fae950f427d10f49c5e846baf7d46cb1856072ca0a73843feea0777b28b1a8aa3ff321b9e46d437ab37993daeb14c8b7176c26435870 SHA512 4f3f50820b1f6bace2c00e016f51585b581ed7f19943e0e8c736ac0aab5429cb11b221d325b302a9bf4828c38a4ee36080d31c99c42e60c66c1fcc303bc0df00
+EBUILD hashable-1.2.4.0.ebuild 1140 BLAKE2B 831b6a786a9d0e8f5914fd4669a9bd8b28c7f113a128d1e802662a187dff72b35a27cdcf8dd5448878ed113dd36c282ee6bb36eefe43d96b96fe115c3a333416 SHA512 8c07cd754ce0034ea1e939944d095744f6bcf7280efe1983a244e327aa71cf7a60d03f320a45b720278cab51463a6ee28f2e61c6330428dd78bd60569680cea0
+MISC metadata.xml 619 BLAKE2B 0c13ff65442edc8bf2e0234b9eb861f11ed9e678062aa2823ee52c9f6be5e0ae671efef678af09481e3fceb07107b4d8c366f1e7f4d5ec873dbad5a03a5bda86 SHA512 d87a8b83ce7d1ffe5024aef8d884b8c6dcd1a01b8c8ae255ddc42848a6f37130853b13bd9a21d8dce2352c6fbf4406fc8286ebaa25d9986764fc668ddb7be050
diff --git a/dev-haskell/hashable/hashable-1.2.1.0.ebuild b/dev-haskell/hashable/hashable-1.2.1.0.ebuild
new file mode 100644
index 000000000000..ff0b81bf60b8
--- /dev/null
+++ b/dev-haskell/hashable/hashable-1.2.1.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.3.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="A class for types that can be converted to a hash value"
+HOMEPAGE="https://github.com/tibbe/hashable"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="alpha amd64 ia64 ppc ppc64 sparc x86"
+IUSE="+cpu_flags_x86_sse2 cpu_flags_x86_sse4_1"
+
+RDEPEND=">=dev-haskell/text-0.11.0.5:=[profile?]
+ >=dev-lang/ghc-6.10.4:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( dev-haskell/hunit
+ >=dev-haskell/quickcheck-2.4.0.1
+ >=dev-haskell/random-1.0 <dev-haskell/random-1.1
+ >=dev-haskell/test-framework-0.3.3
+ dev-haskell/test-framework-hunit
+ >=dev-haskell/test-framework-quickcheck2-0.2.9 )
+"
+
+src_prepare() {
+ # a workaround for <cabal-1.18 #498480
+ hsc2hs tests/Regress/Mmap.{hsc,hs} || die
+}
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag cpu_flags_x86_sse2 sse2) \
+ $(cabal_flag cpu_flags_x86_sse4_1 sse41)
+}
diff --git a/dev-haskell/hashable/hashable-1.2.4.0.ebuild b/dev-haskell/hashable/hashable-1.2.4.0.ebuild
new file mode 100644
index 000000000000..f2a3ae5e0d11
--- /dev/null
+++ b/dev-haskell/hashable/hashable-1.2.4.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.6.9999
+#hackport: flags: sse41:cpu_flags_x86_sse4_1,sse2:cpu_flags_x86_sse2,integer-gmp:gmp
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="A class for types that can be converted to a hash value"
+HOMEPAGE="https://github.com/tibbe/hashable"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~alpha amd64 ~ia64 ~ppc ~ppc64 ~sparc x86"
+IUSE="+cpu_flags_x86_sse2 cpu_flags_x86_sse4_1"
+
+RDEPEND=">=dev-haskell/text-0.11.0.5:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( dev-haskell/hunit
+ >=dev-haskell/quickcheck-2.4.0.1
+ >=dev-haskell/random-1.0 <dev-haskell/random-1.2
+ >=dev-haskell/test-framework-0.3.3
+ dev-haskell/test-framework-hunit
+ >=dev-haskell/test-framework-quickcheck2-0.2.9 )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag cpu_flags_x86_sse2 sse2) \
+ $(cabal_flag cpu_flags_x86_sse4_1 sse41)
+}
diff --git a/dev-haskell/hashable/metadata.xml b/dev-haskell/hashable/metadata.xml
new file mode 100644
index 000000000000..fbc05adb87d3
--- /dev/null
+++ b/dev-haskell/hashable/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>haskell@gentoo.org</email>
+ <name>Gentoo Haskell</name>
+ </maintainer>
+ <longdescription>
+ This package defines a class, 'Hashable', for types that
+ can be converted to a hash value. This class
+ exists for the benefit of hashing-based data
+ structures. The package provides instances for
+ basic types and a way to combine hash values.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">tibbe/hashable</remote-id>
+ </upstream>
+</pkgmetadata>