summaryrefslogtreecommitdiff
path: root/dev-haskell/gtk2hs-buildtools
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-20 14:27:17 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-20 14:27:17 +0000
commit5bb9ff1ee56d2b5e75e01a7f066d8b0cec84ec02 (patch)
tree66e860a5099bcad013f1cf667255dc372a7c11b3 /dev-haskell/gtk2hs-buildtools
parent7218e1b46bceac05841e90472501742d905fb3fc (diff)
gentoo resync : 20.03.2021
Diffstat (limited to 'dev-haskell/gtk2hs-buildtools')
-rw-r--r--dev-haskell/gtk2hs-buildtools/Manifest2
-rw-r--r--dev-haskell/gtk2hs-buildtools/files/gtk2hs-buildtools-0.13.8.0-gcc-11.patch32
-rw-r--r--dev-haskell/gtk2hs-buildtools/gtk2hs-buildtools-0.13.8.0-r1.ebuild37
3 files changed, 71 insertions, 0 deletions
diff --git a/dev-haskell/gtk2hs-buildtools/Manifest b/dev-haskell/gtk2hs-buildtools/Manifest
index 7e233eeb1ec1..4bf63dacad96 100644
--- a/dev-haskell/gtk2hs-buildtools/Manifest
+++ b/dev-haskell/gtk2hs-buildtools/Manifest
@@ -1,3 +1,5 @@
+AUX gtk2hs-buildtools-0.13.8.0-gcc-11.patch 1156 BLAKE2B 5d3485191fd380343412f977baf6e0d434235f012e425118317e5f9c810d4e7b4bde64c5683e912aea098afe84dd9d45f9e458e88214c005943f6ea919ad5987 SHA512 f01350cc6603d0b8cdd4ad4ba4539cd307058c81a4452e8a455c5c612e6a5e1156ffe71518a8fe762e4a56c8f0d173e9cf7fac498b2849e48ce811c511186cce
DIST gtk2hs-buildtools-0.13.8.0.tar.gz 178465 BLAKE2B 73a3bea8e002ba641f08f3104b7c8759dba2649e8b050ac769470c7d67441e86365c4687f2645fed62cb79cbe38947c02c2622224e4568440a8d2745a045b333 SHA512 fa427979f20f10ca8baf38c80c28a5190d18b767046de347950ea799660e1d54939d668c01c469da36d2df6c347f7ba67e2e85f3a7000021f8d37852093e03fd
+EBUILD gtk2hs-buildtools-0.13.8.0-r1.ebuild 903 BLAKE2B a0f2c7dd51499141373eeb955bdb3ef8a682d9617db029add65b7d88dbfc0b2139a0bf3a2d2deeeeeb40cec10d132068b1670494ac25d35b1b426fb54ffe33a3 SHA512 5241a5a51445b76b425d1df8ad5fb415e24f36d321391ee309aea7e8f23e15ac5f1e8d94ea5af98e22a5398c639f1a8e84cac44424edacebbf6340a20d4d7166
EBUILD gtk2hs-buildtools-0.13.8.0.ebuild 850 BLAKE2B 6006f7d07dc50a6eef337b058e23f074b5dc827472a5b49c4ba244ceb7490955a25db68bf6f186d1894613935b398083fb0451a849241439d8e30c1e605df98c SHA512 240a9459683800f4bec0e994a2b6fd2411a82b5284f9e2a14a22caeb6d822e9974015d8311395e9128eb35e8bb336925114ff32e0588b66823bb750b8464941f
MISC metadata.xml 838 BLAKE2B d807057f72ce471a31e5eda4e4c26d8c2e7a6e5c6a932dc577c293d5f52704ce64b055a2dc194fbce71d8028ee7d5dca05f863fa2519fc841f585400d05849de SHA512 81b67b9c4d461b291561a2ee3873c80c257fc0e3e8641724381567d378aafae21f8056b60b00d432a0db60f5795d6b7a78a74cce9e10722b809f46c6701e7feb
diff --git a/dev-haskell/gtk2hs-buildtools/files/gtk2hs-buildtools-0.13.8.0-gcc-11.patch b/dev-haskell/gtk2hs-buildtools/files/gtk2hs-buildtools-0.13.8.0-gcc-11.patch
new file mode 100644
index 000000000000..123c1359ff1b
--- /dev/null
+++ b/dev-haskell/gtk2hs-buildtools/files/gtk2hs-buildtools-0.13.8.0-gcc-11.patch
@@ -0,0 +1,32 @@
+Same fix as https://github.com/visq/language-c/issues/74
+
+"""
+Lexer: allow zeros as line numbers in preprocessed directives
+
+Starting from `gcc-11` initial line numbers not related to
+actual files are marked as zeros. See the "preprocessor:
+Better line info for <builtin> & <command-line>"
+https://gcc.gnu.org/git/?p=gcc.git;a=commitdiff;h=6bf2ff0d52a9
+
+language-c's grammar did not allow it (by accident)
+
+```
+Prelude> Language.C.parseC (Data.ByteString.Char8.pack "# 0 \"/dev/null\"\n") Language.C.nopos
+Left <no file>:: [ERROR] >>> Syntax Error !
+ Lexical error !
+ The character '#' does not fit here.
+```
+
+The change allows '0' in line numbers as well.
+"""
+--- a/c2hs/c/CLexer.x
++++ b/c2hs/c/CLexer.x
+@@ -130,7 +130,7 @@ $white+ ;
+ -- * allows further ints after the file name a la GCC; as the GCC CPP docu
+ -- doesn't say how many ints there can be, we allow an unbound number
+ --
+-\#$space*@int$space*(\"($infname|@charesc)*\"$space*)?(@int$space*)*$eol
++\#$space*@digits$space*(\"($infname|@charesc)*\"$space*)?(@int$space*)*$eol
+ { \pos len str -> setPos (adjustPos (take len str) pos) >> lexToken }
+
+ -- #pragma directive (K&R A12.8)
diff --git a/dev-haskell/gtk2hs-buildtools/gtk2hs-buildtools-0.13.8.0-r1.ebuild b/dev-haskell/gtk2hs-buildtools/gtk2hs-buildtools-0.13.8.0-r1.ebuild
new file mode 100644
index 000000000000..30ffca890e99
--- /dev/null
+++ b/dev-haskell/gtk2hs-buildtools/gtk2hs-buildtools-0.13.8.0-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.6.4
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Tools to build the Gtk2Hs suite of User Interface libraries"
+HOMEPAGE="http://projects.haskell.org/gtk2hs/"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="+closuresignals"
+
+RDEPEND=">=dev-haskell/cabal-1.24.0.0:=[profile?]
+ dev-haskell/fail:=[profile?]
+ dev-haskell/hashtables:=[profile?]
+ dev-haskell/random:=[profile?]
+ >=dev-lang/ghc-7.8.2:=
+"
+DEPEND="${RDEPEND}
+ dev-haskell/alex
+ >=dev-haskell/cabal-1.18.1.3
+ dev-haskell/happy
+"
+
+PATCHES=("${FILESDIR}"/${PN}-0.13.8.0-gcc-11.patch)
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag closuresignals closuresignals)
+}