summaryrefslogtreecommitdiff
path: root/dev-haskell/glob/glob-0.7.14.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-haskell/glob/glob-0.7.14.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-haskell/glob/glob-0.7.14.ebuild')
-rw-r--r--dev-haskell/glob/glob-0.7.14.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-haskell/glob/glob-0.7.14.ebuild b/dev-haskell/glob/glob-0.7.14.ebuild
new file mode 100644
index 000000000000..a469f0329db1
--- /dev/null
+++ b/dev-haskell/glob/glob-0.7.14.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+# ebuild generated by hackport 0.5.1.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+MY_PN="Glob"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Globbing library"
+HOMEPAGE="http://iki.fi/matti.niemenmaa/glob/"
+SRC_URI="mirror://hackage/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/dlist-0.4:=[profile?] <dev-haskell/dlist-0.9:=[profile?]
+ >=dev-haskell/semigroups-0.18:=[profile?] <dev-haskell/semigroups-0.19:=[profile?]
+ >=dev-haskell/transformers-compat-0.3:=[profile?] <dev-haskell/transformers-compat-0.6:=[profile?]
+ >=dev-lang/ghc-7.8.2:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.18.1.3
+ test? ( >=dev-haskell/hunit-1.2 <dev-haskell/hunit-1.6
+ >=dev-haskell/quickcheck-2 <dev-haskell/quickcheck-3
+ >=dev-haskell/test-framework-0.2 <dev-haskell/test-framework-1
+ >=dev-haskell/test-framework-hunit-0.2 <dev-haskell/test-framework-hunit-1
+ >=dev-haskell/test-framework-quickcheck2-0.3 <dev-haskell/test-framework-quickcheck2-1 )
+"
+
+S="${WORKDIR}/${MY_P}"