summaryrefslogtreecommitdiff
path: root/dev-haskell/filestore/filestore-0.6.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-haskell/filestore/filestore-0.6.2.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-haskell/filestore/filestore-0.6.2.ebuild')
-rw-r--r--dev-haskell/filestore/filestore-0.6.2.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/dev-haskell/filestore/filestore-0.6.2.ebuild b/dev-haskell/filestore/filestore-0.6.2.ebuild
new file mode 100644
index 000000000000..ff22aa392912
--- /dev/null
+++ b/dev-haskell/filestore/filestore-0.6.2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+# ebuild generated by hackport 0.5.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Interface for versioning file stores"
+HOMEPAGE="http://hackage.haskell.org/package/filestore"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="+maxcount"
+
+RESTRICT=test # one darcs test fails
+
+RDEPEND=">=dev-haskell/diff-0.2:=[profile?] <dev-haskell/diff-0.4:=[profile?]
+ >=dev-haskell/old-locale-1.0:=[profile?] <dev-haskell/old-locale-1.1:=[profile?]
+ >=dev-haskell/parsec-2:=[profile?] <dev-haskell/parsec-3.2:=[profile?]
+ >=dev-haskell/split-0.1:=[profile?] <dev-haskell/split-0.3:=[profile?]
+ >=dev-haskell/utf8-string-0.3:=[profile?] <dev-haskell/utf8-string-1.1:=[profile?]
+ >=dev-haskell/xml-1.3:=[profile?] <dev-haskell/xml-1.4:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.10
+ test? ( >=dev-haskell/hunit-1.2 <dev-haskell/hunit-1.4
+ dev-haskell/mtl )
+"
+
+src_prepare() {
+ default
+
+ cabal_chdeps \
+ 'directory >= 1.1 && < 1.3' 'directory >= 1.1' \
+ 'directory >= 1.0 && < 1.3' 'directory >= 1.0'
+}
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag maxcount maxcount)
+}