summaryrefslogtreecommitdiff
path: root/dev-haskell/filestore/filestore-0.6.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-haskell/filestore/filestore-0.6.1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-haskell/filestore/filestore-0.6.1.ebuild')
-rw-r--r--dev-haskell/filestore/filestore-0.6.1.ebuild61
1 files changed, 61 insertions, 0 deletions
diff --git a/dev-haskell/filestore/filestore-0.6.1.ebuild b/dev-haskell/filestore/filestore-0.6.1.ebuild
new file mode 100644
index 000000000000..75d53eaeabb7
--- /dev/null
+++ b/dev-haskell/filestore/filestore-0.6.1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.5.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Interface for versioning file stores"
+HOMEPAGE="http://hackage.haskell.org/package/filestore"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="+maxcount"
+
+RESTRICT=test # one darcs test fails
+
+RDEPEND=">=dev-haskell/diff-0.2:=[profile?] <dev-haskell/diff-0.4:=[profile?]
+ >=dev-haskell/old-locale-1.0:=[profile?] <dev-haskell/old-locale-1.1:=[profile?]
+ >=dev-haskell/parsec-2:=[profile?] <dev-haskell/parsec-3.2:=[profile?]
+ >=dev-haskell/split-0.1:=[profile?] <dev-haskell/split-0.3:=[profile?]
+ >=dev-haskell/utf8-string-0.3:=[profile?] <dev-haskell/utf8-string-1.1:=[profile?]
+ >=dev-haskell/xml-1.3:=[profile?] <dev-haskell/xml-1.4:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.10
+ test? ( >=dev-haskell/hunit-1.2 <dev-haskell/hunit-1.3
+ dev-haskell/mtl )
+"
+DEPEND+="
+ test? ( dev-vcs/darcs
+ dev-vcs/git
+ dev-vcs/mercurial
+ )
+"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-ghc-8.patch
+
+ cabal_chdeps \
+ 'time >= 1.1 && < 1.6' 'time >= 1.1' \
+ 'process >= 1.0 && < 1.3' 'process >= 1.0'
+}
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag maxcount maxcount)
+}
+
+src_test() {
+ export HOME=${T}/
+ git config --global user.email "git@src_test"
+ git config --global user.name "Mr. ${P} The Test"
+
+ haskell-cabal_src_test
+}