summaryrefslogtreecommitdiff
path: root/dev-haskell/filepattern
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /dev-haskell/filepattern
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'dev-haskell/filepattern')
-rw-r--r--dev-haskell/filepattern/Manifest3
-rw-r--r--dev-haskell/filepattern/filepattern-0.1.2.ebuild27
-rw-r--r--dev-haskell/filepattern/metadata.xml26
3 files changed, 56 insertions, 0 deletions
diff --git a/dev-haskell/filepattern/Manifest b/dev-haskell/filepattern/Manifest
new file mode 100644
index 000000000000..76e34091eea8
--- /dev/null
+++ b/dev-haskell/filepattern/Manifest
@@ -0,0 +1,3 @@
+DIST filepattern-0.1.2.tar.gz 15737 BLAKE2B c90064a18115538cf7e1d5b26cb46971b86b0c7fb4f8e503db7cf7097cf1f19c8c1fdc3e89a0a90dbf915c95b71109359e94ad8f225a4cb450ad6a5fa71994d7 SHA512 16866d70efdf55ee4e6b246eb7f7300c9ad4c148d8136d817f601b9c0cac95eb1ddaf57ab0b6fad539298b55128fe5c255c31fd152a713bf312488eae823da23
+EBUILD filepattern-0.1.2.ebuild 669 BLAKE2B 20654617e100498c1ca2874de1f550da0274f071a9cf52b1311f45ff3690a5b913cb4b58dca8e59de9f4cb2957ae36d43980b2614241990570a1dd0e0a659af4 SHA512 11c8b6b56fff007869193d4a5bf99a48b1124bcf5081fce185ee0d826f98554f006738a829b1fa1eab8b2ca845a0935c28db85522a7fd0e8133da65262508b0b
+MISC metadata.xml 1020 BLAKE2B e985a0ac1c7494d46568c688397f5beda0671258e4a13e57a1d239276b7e02c02ceccd1b2850513b4325167b5f881f4deeb7f25b76c113f67f15803b5ba234be SHA512 535e11e332bc2128d2e282af750459f6fd4ac84aff0da8f1346558d8c6480dbbdf421d334be61f0aff333d56886bc9714bae7ab921b900c485c178577b404934
diff --git a/dev-haskell/filepattern/filepattern-0.1.2.ebuild b/dev-haskell/filepattern/filepattern-0.1.2.ebuild
new file mode 100644
index 000000000000..148807303154
--- /dev/null
+++ b/dev-haskell/filepattern/filepattern-0.1.2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.6.4
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="File path glob-like matching"
+HOMEPAGE="https://github.com/ndmitchell/filepattern#readme"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/extra-1.6.2:=[profile?]
+ >=dev-haskell/semigroups-0.18:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.18
+ test? ( >=dev-haskell/quickcheck-2.0 )
+"
diff --git a/dev-haskell/filepattern/metadata.xml b/dev-haskell/filepattern/metadata.xml
new file mode 100644
index 000000000000..9b145f120dc0
--- /dev/null
+++ b/dev-haskell/filepattern/metadata.xml
@@ -0,0 +1,26 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>haskell@gentoo.org</email>
+ <name>Gentoo Haskell</name>
+ </maintainer>
+ <longdescription>
+ A library for matching files using patterns such as @\&quot;src\/**\/*.png\&quot;@ for all @.png@ files
+ recursively under the @src@ directory. Features:
+
+ * All matching is /O(n)/.
+
+ * See &quot;System.FilePattern&quot; and @?==@ simple matching and semantics.
+
+ * Use @match@ and @substitute@ to extract suitable
+ strings from the @*@ and @**@ matches, and substitute them back into other patterns.
+
+ * Use @step@ and @matchMany@ to perform bulk matching
+ of many patterns against many paths simultaneously.
+
+ * Use &quot;System.FilePattern.Directory&quot; to perform optimised directory traverals using patterns.
+
+ Originally taken from the &lt;https://hackage.haskell.org/package/shake Shake library&gt;.
+ </longdescription>
+</pkgmetadata>