summaryrefslogtreecommitdiff
path: root/dev-haskell/file-location
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-haskell/file-location
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-haskell/file-location')
-rw-r--r--dev-haskell/file-location/Manifest4
-rw-r--r--dev-haskell/file-location/file-location-0.4.9-r1.ebuild35
-rw-r--r--dev-haskell/file-location/file-location-0.4.9.ebuild28
-rw-r--r--dev-haskell/file-location/metadata.xml42
4 files changed, 109 insertions, 0 deletions
diff --git a/dev-haskell/file-location/Manifest b/dev-haskell/file-location/Manifest
new file mode 100644
index 000000000000..01867e66e817
--- /dev/null
+++ b/dev-haskell/file-location/Manifest
@@ -0,0 +1,4 @@
+DIST file-location-0.4.9.tar.gz 6959 BLAKE2B 1cc083a9fb71fb80a11b56e27d8fc468f806d1417efbaf618ea07a4f68df5addf7c479bf5490d50bf07b34ff6babdaefc11536068c15bff274b07bbf4189be74 SHA512 cbea7ef5a6797efd242219a32c7d46b5a0fe2b20d4c93e7ab758cf27519b021c2e2c34ab91d4eedfba8a61a51f81312346d575f8c83296b87b1f7bea8985d40f
+EBUILD file-location-0.4.9-r1.ebuild 881 BLAKE2B 7fca8873c49653ef64c34319f76faa9281e5eb0ccfc2707e6e1d937c8e52e52cf6ad4186e6e5558c1731892ce24bc6fc82dd3e890f971e7f617ae44f2b6fbc9c SHA512 5fa82b5758a587f64849546d33e4fdcc2bd44d46e9e197753d20f9b86445e0b0ae2c17c3f9f6f7176fa3da021f27abe52c726725b7b624c95846369e5fdd57da
+EBUILD file-location-0.4.9.ebuild 774 BLAKE2B 9dd1bde12108bb2b9bc20a814e56b8097bb56d269900b6f52e04f39ee9596ae22bc7c0564f01475e73e78445ce264c6a8363bfd631974f6fd5da5429cadb94c0 SHA512 3b930e24b6859a5e2e1aa70fa3b117d5041b08888b46b2a73e9392795142875217f4c2afbfc8384ab8e3535d16f50510bafa51e82242b6db5252a060bfae5b33
+MISC metadata.xml 1438 BLAKE2B 7790bc6d1bab559c7961458b3fee13af2861c8bda34d39045044179e973892fbe01471c53faa9bcf32f3a4bec902f1590bead1b9bed2e6d653b52ad9438be230 SHA512 becf41f547c76f329ae69bd5518a96cffcdf3161c05d9ffaecf3f6ba91d9a20855e3aefba473c37d4e7d004fc5d923459f50fd8a7a4f657ccfb52482d15c753e
diff --git a/dev-haskell/file-location/file-location-0.4.9-r1.ebuild b/dev-haskell/file-location/file-location-0.4.9-r1.ebuild
new file mode 100644
index 000000000000..ba606f8ae4be
--- /dev/null
+++ b/dev-haskell/file-location/file-location-0.4.9-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.5.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="common functions that show file location information"
+HOMEPAGE="https://github.com/gregwebs/FileLocation.hs"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RESTRICT=test # error stack changed from ghc-7.10
+
+RDEPEND="dev-haskell/hunit:=[profile?]
+ dev-haskell/lifted-base:=[profile?]
+ >=dev-haskell/th-orphans-0.9:=[profile?]
+ >=dev-haskell/transformers-0.2:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+"
+
+src_prepare() {
+ cabal_chdeps \
+ 'transformers >= 0.2 && < 0.5' 'transformers >= 0.2'
+}
diff --git a/dev-haskell/file-location/file-location-0.4.9.ebuild b/dev-haskell/file-location/file-location-0.4.9.ebuild
new file mode 100644
index 000000000000..a245d34a0e23
--- /dev/null
+++ b/dev-haskell/file-location/file-location-0.4.9.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.5.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="common functions that show file location information"
+HOMEPAGE="https://github.com/gregwebs/FileLocation.hs"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-haskell/hunit:=[profile?]
+ dev-haskell/lifted-base:=[profile?]
+ >=dev-haskell/th-orphans-0.9:=[profile?]
+ >=dev-haskell/transformers-0.2:=[profile?] <dev-haskell/transformers-0.5:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+"
diff --git a/dev-haskell/file-location/metadata.xml b/dev-haskell/file-location/metadata.xml
new file mode 100644
index 000000000000..fd1840e49f39
--- /dev/null
+++ b/dev-haskell/file-location/metadata.xml
@@ -0,0 +1,42 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>haskell@gentoo.org</email>
+ <name>Gentoo Haskell</name>
+ </maintainer>
+ <longdescription>
+ Common debugging/error/exception functions that give file location information
+
+ &gt; $(err "OH NO!")
+ &gt;
+ &gt; main:Main main.hs:16:1 OH NO!
+
+ Notice how it displays package:module file:line:character
+ It exposes the functions err (error), undef (undefined), and trc (Debug.Trace.trace). All of these behave the same as their normal counterpart but also spit out a location.
+
+ Here is my favorite helper, debug, which is like trace but just show the value.
+
+ &gt; debug [1,2,3]
+ &gt;
+ &gt; DEBUG: [1,2,3]
+ &gt; [1,2,3]
+
+ And The Template Haskell version.
+
+ &gt; $(dbg) [1,2,3]
+ &gt;
+ &gt; DEBUG main:Main main.hs:1:3 [1,2,3]
+ &gt; [1,2,3]
+
+ Also there is a version of thrwIO that gives location information
+ &gt; ($(thrwIO) $ AException) `catch` \e -&gt; putStrLn ("Caught " ++ show (e :: AException))
+ &gt;
+ &gt; Caught AException "main:Main test/main.hs:25:6"
+
+ See module for a listing of all the functions with short descriptions, and the homepage for some more examples https://github.com/gregwebs/ErrorLocation.hs
+ </longdescription>
+ <upstream>
+ <remote-id type="github">gregwebs/FileLocation.hs</remote-id>
+ </upstream>
+</pkgmetadata>