summaryrefslogtreecommitdiff
path: root/dev-haskell/edit-distance-vector
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /dev-haskell/edit-distance-vector
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'dev-haskell/edit-distance-vector')
-rw-r--r--dev-haskell/edit-distance-vector/Manifest3
-rw-r--r--dev-haskell/edit-distance-vector/edit-distance-vector-1.0.0.4.ebuild27
-rw-r--r--dev-haskell/edit-distance-vector/metadata.xml22
3 files changed, 52 insertions, 0 deletions
diff --git a/dev-haskell/edit-distance-vector/Manifest b/dev-haskell/edit-distance-vector/Manifest
new file mode 100644
index 000000000000..922b72869aef
--- /dev/null
+++ b/dev-haskell/edit-distance-vector/Manifest
@@ -0,0 +1,3 @@
+DIST edit-distance-vector-1.0.0.4.tar.gz 5819 BLAKE2B 8658c52e64e704dd5c52bae0e63ae0b4d84c88d6cb1e3ecdafb05191dc70e3dfdec34001b2c287ec62703eb7ecdbac9b127b3dd084bc4e484e70cd778d31913f SHA512 8d7ef7c6ca971aec5efc2e90adff2584c1e4f996df3ad4f6111f790fd88fcce1814111eb3a3bbe07d8455b03ade98f11e6343c4746e895be2ba9b82a86a33e6d
+EBUILD edit-distance-vector-1.0.0.4.ebuild 686 BLAKE2B f8335bbe568dcdb9262dbfaad0f19ad9038be59c0c815b203c8501fab1d9450e36e71153e587dbc0723926f49165c8c7d79709973fcffa072d8bfb7fb98c98b5 SHA512 a298e2104eab8ed9cd89267811fd8eb90f1f874420c4a757703da64af0f0007995f1e10d830edc9778995147bef5c4782c6bdcebf6526a55722555472a65dc01
+MISC metadata.xml 715 BLAKE2B f806edd036f5aff0827ab5a5e661b1878a37fd791681d235eaa4dd2ddfac2432cc5544cb0bb91af88b59b01f6c443cfa79ec711cadf9f02732ae17888c8bc17d SHA512 7631013f455be1ab70fcf1a596a3c21c9e807bda921020ce3b073a5a4f97dd9d4c3825d14693f3c118ff684e3694cf72d4258ecec3edc38988ad26d2d5e3359d
diff --git a/dev-haskell/edit-distance-vector/edit-distance-vector-1.0.0.4.ebuild b/dev-haskell/edit-distance-vector/edit-distance-vector-1.0.0.4.ebuild
new file mode 100644
index 000000000000..e61c98b7c569
--- /dev/null
+++ b/dev-haskell/edit-distance-vector/edit-distance-vector-1.0.0.4.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.6.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Calculate edit distances and edit scripts between vectors"
+HOMEPAGE="https://github.com/thsutton/edit-distance-vector"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/vector-0.8:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.10
+ test? ( dev-haskell/quickcheck
+ dev-haskell/quickcheck-instances )
+"
diff --git a/dev-haskell/edit-distance-vector/metadata.xml b/dev-haskell/edit-distance-vector/metadata.xml
new file mode 100644
index 000000000000..c2c7c2767205
--- /dev/null
+++ b/dev-haskell/edit-distance-vector/metadata.xml
@@ -0,0 +1,22 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>haskell@gentoo.org</email>
+ <name>Gentoo Haskell</name>
+ </maintainer>
+ <longdescription>
+ An implementation of the Wagner-Fischer dynamic programming algorithm to
+ find the optimal edit script and cost between two sequences.
+
+ The implementation in this package is specialised to sequences represented
+ with &quot;Data.Vector&quot; but is otherwise agnostic to:
+
+ * The type of values in the vectors;
+
+ * The type representing edit operations; and
+
+ * The type representing the cost of operations.
+
+ </longdescription>
+</pkgmetadata>