summaryrefslogtreecommitdiff
path: root/dev-haskell/echo
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /dev-haskell/echo
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'dev-haskell/echo')
-rw-r--r--dev-haskell/echo/Manifest3
-rw-r--r--dev-haskell/echo/echo-0.1.3.ebuild37
-rw-r--r--dev-haskell/echo/metadata.xml22
3 files changed, 62 insertions, 0 deletions
diff --git a/dev-haskell/echo/Manifest b/dev-haskell/echo/Manifest
new file mode 100644
index 000000000000..2bb51fce0bfc
--- /dev/null
+++ b/dev-haskell/echo/Manifest
@@ -0,0 +1,3 @@
+DIST echo-0.1.3.tar.gz 5373 BLAKE2B 3710de35b42e39f7ff9d2e5c2e32ae4c1e863f9ae844ada25dbb653aafd6ed261357c3b5046e9e0cabb03dd4de4f6252272a2b643087a61d1df5f26de329e588 SHA512 26a2398af231a8805b6b0a866348f848b8b8f21fe95a2fa3c781aaeae150df978335df573d46d5b07d7e4df19d6377d997f85c77049abaf0c5cb3e9998439c6f
+EBUILD echo-0.1.3.ebuild 794 BLAKE2B 19ee02277ccf385b1fd97aa1ef74c4c1b2758f36d6fe72c0624ea91003e575b15d56f3a702c653529f7244bea472f75a6681bf6d0679bf11ec8a94d801ea7997 SHA512 7d768f30725201963ec785a9b2d4f7e69c4aa1514ad944b164eef59f80ff815a4d2ae50a22340d1ccc26af50ab40bad048ed608bec35fae1b23c1427ddcfbe74
+MISC metadata.xml 955 BLAKE2B c282b00f86558234927b728f74a97e10aec67e7d3694f113e6ad057e6c64840d7c076f0e8bc7a9b47a1f341808450e090b57a890e3e34a2bcf8d7b4992965d0f SHA512 7272f1a63a881b6677bf7b49eb40c79c4fe1cfe891e7572c2456bf8d6988128c89365f1365524abe2428ab3a62fd2f2944d9509accecadbeb2979a0ba4c289aa
diff --git a/dev-haskell/echo/echo-0.1.3.ebuild b/dev-haskell/echo/echo-0.1.3.ebuild
new file mode 100644
index 000000000000..628da37e9f37
--- /dev/null
+++ b/dev-haskell/echo/echo-0.1.3.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+# ebuild generated by hackport 0.5.3.9999
+#hackport: flags: example:examples
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="A cross-platform, cross-console way to handle echoing terminal input"
+HOMEPAGE="https://github.com/RyanGlScott/echo"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+RDEPEND=">=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.10
+"
+
+src_prepare() {
+ default
+
+ cabal_chdeps \
+ 'process >= 1.0.1.1 && < 1.5' 'process >= 1.0.1.1'
+}
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag examples example)
+}
diff --git a/dev-haskell/echo/metadata.xml b/dev-haskell/echo/metadata.xml
new file mode 100644
index 000000000000..1ccd56c6a779
--- /dev/null
+++ b/dev-haskell/echo/metadata.xml
@@ -0,0 +1,22 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>haskell@gentoo.org</email>
+ <name>Gentoo Haskell</name>
+ </maintainer>
+ <longdescription>
+ The @base@ library exposes the @hGetEcho@ and @hSetEcho@ functions
+ for querying and setting echo status, but unfortunately, neither
+ function works with MinTTY consoles on Windows. This is a serious
+ issue, since @hGetEcho@ and @hSetEcho@ are often used to disable
+ input echoing when a program prompts for a password, so many
+ programs will reveal your password as you type it on MinTTY!
+
+ This library provides an alternative interface which works
+ with both MinTTY and other consoles. An example is included
+ which demonstrates how one might prompt for a password using
+ this library. To build it, make sure to configure with the
+ @-fexample@ flag.
+ </longdescription>
+</pkgmetadata>