summaryrefslogtreecommitdiff
path: root/dev-haskell/drift
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-haskell/drift
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-haskell/drift')
-rw-r--r--dev-haskell/drift/Manifest4
-rw-r--r--dev-haskell/drift/drift-2.4.2.ebuild35
-rw-r--r--dev-haskell/drift/files/drift-2.4.2-ghc-7.10.patch22
-rw-r--r--dev-haskell/drift/metadata.xml7
4 files changed, 68 insertions, 0 deletions
diff --git a/dev-haskell/drift/Manifest b/dev-haskell/drift/Manifest
new file mode 100644
index 000000000000..c0fee5a2541d
--- /dev/null
+++ b/dev-haskell/drift/Manifest
@@ -0,0 +1,4 @@
+AUX drift-2.4.2-ghc-7.10.patch 581 BLAKE2B 466fba075f3428dccdc6dc8dd5c6c18367bf37fed6d13b3d4d9bef02e9351d558a0c66ea99b14f6ff8a7f51c8c6a67ae791847a6eca0e64255adaa3c5c205bf2 SHA512 33d6ff669da9adf11f2a595748b6b1d726729186b0846c47951bb8fdc900d7c17ddf5cc5fc27a3e77c8766365c3b4e1f33b49a35a8f6f5ab88e7223fb1361014
+DIST DrIFT-2.4.2.tar.gz 69676 BLAKE2B 8b072b88e52f9106eeddd62c391805b17bab0cea59e6ac8eedb1c88d22dce91ba697174b2380ee2d2fd41036116fa41778d119bfa5b673444ee466815e49c7f0 SHA512 c6f36e9efad171c165ea8028b7d251e66d5b410aaa51a74e4b8745cf76b77fcfdf6f641fd375f15663b559ae6b8939622a175ba321537afdbb2a114a1550f7db
+EBUILD drift-2.4.2.ebuild 783 BLAKE2B f783cf1c965d42ada0f1431b2e9072d861abfae2b5ee039adae592ee5e88b78308e5bd0affc4a8521e19e7e4f2afbd33928c25ecabb51ca16ca5598bcd58d0c7 SHA512 eea2cec56304f19b3ada3267ce3cdb51bb2347cd6ae10d88721038b21fdd745ee1ecbf181a393ddd7e77a7737b74f48b3e457d7d86257cbd37130f4c1cd5f16c
+MISC metadata.xml 217 BLAKE2B 41b11b7399431ee96c40a11373f20b12940ed7bb1fc77b1619212b2a57a3b34b11b77838d4ac51c1ddb80caab1030224e28567836e5d0a17b4ea6bd1afa2523c SHA512 63f267082f4ba17f6a1226d1c5a14d85d17e0f7a84857605933418d875d09cfffe2a0ca304b8a171dcae59169330fcc3cfca9d6f4c9ce24d135f1125a6d06c70
diff --git a/dev-haskell/drift/drift-2.4.2.ebuild b/dev-haskell/drift/drift-2.4.2.ebuild
new file mode 100644
index 000000000000..af0147fc3568
--- /dev/null
+++ b/dev-haskell/drift/drift-2.4.2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+# ebuild generated by hackport 0.5.2.9999
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour"
+inherit eutils haskell-cabal
+
+MY_PN="DrIFT"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Program to derive type class instances"
+HOMEPAGE="http://repetae.net/computer/haskell/DrIFT/"
+SRC_URI="mirror://hackage/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="alpha amd64 ia64 ppc ppc64 sparc x86"
+IUSE=""
+
+RDEPEND="dev-haskell/old-time:=[profile?]
+ dev-haskell/random:=[profile?]
+ >=dev-lang/ghc-6.10.4:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-ghc-7.10.patch
+}
diff --git a/dev-haskell/drift/files/drift-2.4.2-ghc-7.10.patch b/dev-haskell/drift/files/drift-2.4.2-ghc-7.10.patch
new file mode 100644
index 000000000000..c45a2945fd2a
--- /dev/null
+++ b/dev-haskell/drift/files/drift-2.4.2-ghc-7.10.patch
@@ -0,0 +1,22 @@
+diff --git a/src/ParseLib2.hs b/src/ParseLib2.hs
+index 730e4be..a7406fa 100644
+--- a/src/ParseLib2.hs
++++ b/src/ParseLib2.hs
+@@ -34,2 +34,3 @@ module ParseLib2
+ import Data.Char
++import Control.Applicative hiding ( many )
+ import Control.Monad
+@@ -49,2 +50,6 @@ instance Functor Parser where
+
++instance Applicative Parser where
++ pure = return
++ (<*>) = ap -- defined in Control.Monad
++
+ instance Monad Parser where
+@@ -58,2 +63,6 @@ instance Monad Parser where
+
++instance Alternative Parser where
++ (<|>) = mplus
++ empty = mzero
++
+ instance MonadPlus Parser where
diff --git a/dev-haskell/drift/metadata.xml b/dev-haskell/drift/metadata.xml
new file mode 100644
index 000000000000..522384de8446
--- /dev/null
+++ b/dev-haskell/drift/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>haskell@gentoo.org</email>
+</maintainer>
+</pkgmetadata>