summaryrefslogtreecommitdiff
path: root/dev-haskell/double-conversion
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-02 14:09:07 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-02 14:09:07 +0100
commitb17a3ef12038de50228bade1f05502c74e135321 (patch)
tree9026dffec53f92cba48ca9a500a4f778e6304380 /dev-haskell/double-conversion
parent3cf7c3ef441822c889356fd1812ebf2944a59851 (diff)
gentoo resync : 02.09.2020
Diffstat (limited to 'dev-haskell/double-conversion')
-rw-r--r--dev-haskell/double-conversion/Manifest3
-rw-r--r--dev-haskell/double-conversion/double-conversion-2.0.2.0.ebuild38
-rw-r--r--dev-haskell/double-conversion/metadata.xml26
3 files changed, 67 insertions, 0 deletions
diff --git a/dev-haskell/double-conversion/Manifest b/dev-haskell/double-conversion/Manifest
new file mode 100644
index 000000000000..8ea8e545652a
--- /dev/null
+++ b/dev-haskell/double-conversion/Manifest
@@ -0,0 +1,3 @@
+DIST double-conversion-2.0.2.0.tar.gz 7023616 BLAKE2B ecdd9ff171a976f48390626eda39a23f3e6b9f3ec204515a9730ebc22bb6a49b40baf77f5c12dc01f47c90225055d5c1199b00e739ef809861bf564d3aaa38df SHA512 1713c4e8a28de2ee85e1f312dc12d30a9c6d7a139d89f04ea88048578ce65c8bdf62ded90b92bce011955b95867ca95a623a5109758276a29ba7b6843fbe37eb
+EBUILD double-conversion-2.0.2.0.ebuild 924 BLAKE2B 342183e5abfb43fdf770531afe534c4f108c9f1924be836e3b73b5ac14f83a220b056df3ad74ba1eb1f8a183a43ffc14b13d615ad654ed7fcc85875370ed2096 SHA512 98506d9ee98593c51601d6d0a65830fc13624c141752936cc575ca817dd6936b3f58cd7dc7ea3f473d1b737db32c09a6159f815d89cb06b6997757168e9307ff
+MISC metadata.xml 1001 BLAKE2B db7b2d3e4456d83adcea266a44104a495b72c8da397beb3d41741cfb4e379eacf1d8bc2db94455b7d0d4a51555c47195f4db0ec281d970c24c83b19b4a9e97d6 SHA512 5a5d2fb52baa372f24d4e060b05bcf1fd8836ee5699d461bb11673a74c42d5fb714a208a7ee9151a6a7ace2ebb326dbe187a95df162481f9151d79ff85b2e84f
diff --git a/dev-haskell/double-conversion/double-conversion-2.0.2.0.ebuild b/dev-haskell/double-conversion/double-conversion-2.0.2.0.ebuild
new file mode 100644
index 000000000000..721be4fc964b
--- /dev/null
+++ b/dev-haskell/double-conversion/double-conversion-2.0.2.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+# ebuild generated by hackport 0.5.1.9999
+#hackport: flags: -developer
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Fast conversion between double precision floating point and text"
+HOMEPAGE="https://github.com/bos/double-conversion"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RESTRICT=test # fails to compare 0.0 with 0.0
+
+RDEPEND=">=dev-haskell/text-0.11.0.8:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+ sys-devel/gcc:*[cxx]
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( dev-haskell/hunit
+ dev-haskell/test-framework
+ dev-haskell/test-framework-hunit
+ dev-haskell/test-framework-quickcheck2 )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=-developer
+}
diff --git a/dev-haskell/double-conversion/metadata.xml b/dev-haskell/double-conversion/metadata.xml
new file mode 100644
index 000000000000..b9abb6a6f244
--- /dev/null
+++ b/dev-haskell/double-conversion/metadata.xml
@@ -0,0 +1,26 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>haskell@gentoo.org</email>
+ <name>Gentoo Haskell</name>
+ </maintainer>
+ <longdescription>
+ A library that performs fast, accurate conversion between double
+ precision floating point and text.
+
+ This library is implemented as bindings to the C++
+ @double-conversion@ library written by Florian Loitsch at Google:
+ &lt;http://code.google.com/p/double-conversion/&gt;.
+
+ The 'Text' versions of these functions are about 30 times faster
+ than the default 'show' implementation for the 'Double' type.
+
+ The 'ByteString' versions are /slower/ than the 'Text' versions;
+ roughly half the speed. (This seems to be due to the cost of
+ allocating 'ByteString' values via @malloc@.)
+
+ As a final note, be aware that the @bytestring-show@ package is
+ about 50% slower than simply using 'show'.
+ </longdescription>
+</pkgmetadata>