summaryrefslogtreecommitdiff
path: root/dev-haskell/dbus-core
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-haskell/dbus-core
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-haskell/dbus-core')
-rw-r--r--dev-haskell/dbus-core/Manifest4
-rw-r--r--dev-haskell/dbus-core/dbus-core-0.9.3-r3.ebuild57
-rw-r--r--dev-haskell/dbus-core/files/dbus-core-0.9.3-ghc-7.10.patch96
-rw-r--r--dev-haskell/dbus-core/metadata.xml11
4 files changed, 168 insertions, 0 deletions
diff --git a/dev-haskell/dbus-core/Manifest b/dev-haskell/dbus-core/Manifest
new file mode 100644
index 000000000000..6ce1c5b14fa9
--- /dev/null
+++ b/dev-haskell/dbus-core/Manifest
@@ -0,0 +1,4 @@
+AUX dbus-core-0.9.3-ghc-7.10.patch 2960 BLAKE2B cbf0294948a042fd3135558755ed0dd61aede38cbb0777b62c8b6ca27fe68bf20622914264d0f50acc20a9e99f25e8461b474e0fc9d89c9eddc87320e5b55087 SHA512 f64631810064c8598264835f58a8bc952160e24a14977bd440cb34895dc4a3a28dfa1122e045f5c16a1ecb3245207b1a5b2349f51f65facfd4eee08b0e203a6a
+DIST dbus-core-0.9.3.tar.gz 216896 BLAKE2B affa443c08cfcc978aeb57a9b73be9afd4f0650e1fa363821688ad7c42439e6446f687f666acef793b95ba65b134bfd7c35968337dbd4c3878c8a8be9b8abe01 SHA512 4eee88958a49a0e0280744b490b9bc71e27f7f7fb32cc8ce34487439a124ba5fe72cb6b006781a03a41e87bdaeb2975fd19374fc19f699f7ad011a9b821ed32d
+EBUILD dbus-core-0.9.3-r3.ebuild 2093 BLAKE2B 5e7d7c82fcea451cb68fb43d9fc0e1f297856955bb16154fc7fd8f1975371606a22ead343a74e0ca48d5b3d8d14542ab5e2a282707a2254d1ddd53138413793e SHA512 e4d7eea9210617f6c7d3ad2f81e603fc16d7c9a8f6488f648fcecbac889554bb5476aa72aab3500d1f70d34b91067591a4248ce11dd13f4f59b15bb34e543755
+MISC metadata.xml 330 BLAKE2B a8f740494ea67b7eb5feacfd853aec03ecddd42c3d59cdaac045a82100b15d4663ec64a9fa1aa509dea37f63e825b14436dd931cfe47c45107bff4718ae62c61 SHA512 55edf794d4db633aeffb156a8f35bf05967fefc4d1e3c342f8a360b4f5c3260a150488af3fdf8410204cb7ae9c8d0cf5a98374638d8c85737e5eb4e24119e063
diff --git a/dev-haskell/dbus-core/dbus-core-0.9.3-r3.ebuild b/dev-haskell/dbus-core/dbus-core-0.9.3-r3.ebuild
new file mode 100644
index 000000000000..5bda653667e7
--- /dev/null
+++ b/dev-haskell/dbus-core/dbus-core-0.9.3-r3.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Low-level D-Bus protocol implementation"
+HOMEPAGE="https://john-millikin.com/software/dbus-core/"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/binary-0.4:=[profile?]
+ >=dev-haskell/data-binary-ieee754-0.3:=[profile?] <dev-haskell/data-binary-ieee754-0.5:=[profile?]
+ =dev-haskell/libxml-sax-0.7*:=[profile?]
+ >=dev-haskell/network-2.2:=[profile?]
+ >=dev-haskell/parsec-2.0:=[profile?] <dev-haskell/parsec-3.2:=[profile?]
+ >=dev-haskell/text-0.11.1.5:=[profile?]
+ >=dev-haskell/vector-0.7:=[profile?]
+ =dev-haskell/xml-types-0.3*:=[profile?]
+ >=dev-lang/ghc-6.10.4:="
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-ghc-7.10.patch
+
+ if has_version "<dev-haskell/haddock-2.9.2"; then
+ # Workaround http://hackage.haskell.org/trac/hackage/ticket/626
+ # The haddock --hoogle option does not like unicode characters, which causes
+ # haddock 2.7.2 to fail like:
+ # haddock: internal Haddock or GHC error: dist/doc/html/enumerator/enumerator.txt: commitAndReleaseBuffer: invalid argument (Invalid or incomplete multibyte or wide character)
+ sed -e 's@&#8208;@-@g' \
+ -e "s@&#8217;@'@g" \
+ -i "${S}/hs/DBus/Connection.hs" \
+ -i "${S}/hs/DBus/Client/Internal.hs" \
+ -i "${S}/hs/DBus/Client/Simple.hs" \
+ -i "${S}/hs/DBus/Message/Internal.hs" \
+ -i "${S}/hs/DBus/Types/Internal.hs" \
+ -i "${S}/hs/DBus/Wire/Internal.hs"
+ fi
+ cabal_chdeps \
+ 'binary >= 0.4 && < 0.6' 'binary >= 0.4' \
+ 'bytestring >= 0.9 && < 0.10' 'bytestring >= 0.9' \
+ 'containers >= 0.1 && < 0.5' 'containers >= 0.1' \
+ 'network >= 2.2 && < 2.4' 'network >= 2.2' \
+ 'text >= 0.11.1.5 && < 0.12' 'text >= 0.11.1.5' \
+ 'unix >= 2.2 && < 2.6' 'unix >= 2.2' \
+ 'vector >= 0.7 && < 0.10' 'vector >= 0.7'
+}
diff --git a/dev-haskell/dbus-core/files/dbus-core-0.9.3-ghc-7.10.patch b/dev-haskell/dbus-core/files/dbus-core-0.9.3-ghc-7.10.patch
new file mode 100644
index 000000000000..402df007e7df
--- /dev/null
+++ b/dev-haskell/dbus-core/files/dbus-core-0.9.3-ghc-7.10.patch
@@ -0,0 +1,96 @@
+diff --git a/hs/DBus/Connection/Authentication.hs b/hs/DBus/Connection/Authentication.hs
+index b909a38..c33d311 100644
+--- a/hs/DBus/Connection/Authentication.hs
++++ b/hs/DBus/Connection/Authentication.hs
+@@ -25,3 +25,4 @@ module DBus.Connection.Authentication
+ import Prelude hiding (getLine, head)
+-import Control.Monad (liftM)
++import Control.Applicative
++import Control.Monad
+ import qualified Data.ByteString
+@@ -58,2 +59,9 @@ data Auth a = Auth
+
++instance Functor Auth where
++ fmap = liftM
++
++instance Applicative Auth where
++ pure = return
++ (<*>) = ap -- defined in Control.Monad
++
+ instance Monad Auth where
+diff --git a/hs/DBus/Introspection.hs b/hs/DBus/Introspection.hs
+index 96ff4a3..da82812 100644
+--- a/hs/DBus/Introspection.hs
++++ b/hs/DBus/Introspection.hs
+@@ -29,3 +29,4 @@ module DBus.Introspection
+ ) where
+-import Control.Monad ((>=>))
++import Control.Applicative
++import Control.Monad
+ import Control.Monad.ST (runST)
+@@ -176,2 +177,9 @@ newtype XmlWriter a = XmlWriter { runXmlWriter :: Maybe (a, Text) }
+
++instance Functor XmlWriter where
++ fmap = liftM
++
++instance Applicative XmlWriter where
++ pure = return
++ (<*>) = ap -- defined in Control.Monad
++
+ instance Monad XmlWriter where
+diff --git a/hs/DBus/Types/Internal.hs b/hs/DBus/Types/Internal.hs
+index 7f5d9c5..7c73afe 100644
+--- a/hs/DBus/Types/Internal.hs
++++ b/hs/DBus/Types/Internal.hs
+@@ -5,2 +5,3 @@
+ {-# LANGUAGE IncoherentInstances #-}
++{-# LANGUAGE FlexibleContexts #-}
+
+diff --git a/hs/DBus/Util/MonadError.hs b/hs/DBus/Util/MonadError.hs
+index 33b51ed..ef01df2 100644
+--- a/hs/DBus/Util/MonadError.hs
++++ b/hs/DBus/Util/MonadError.hs
+@@ -23,2 +23,6 @@ module DBus.Util.MonadError
+ ) where
++
++import Control.Applicative
++import Control.Monad
++
+ newtype ErrorM e a = ErrorM { runErrorM :: Either e a }
+@@ -30,2 +34,6 @@ instance Functor (ErrorM e) where
+
++instance Applicative (ErrorM e) where
++ pure = return
++ (<*>) = ap -- defined in Control.Monad
++
+ instance Monad (ErrorM e) where
+@@ -41,2 +49,9 @@ newtype ErrorT e m a = ErrorT { runErrorT :: m (Either e a) }
+
++instance Monad m => Functor (ErrorT e m) where
++ fmap = liftM
++
++instance Monad m => Applicative (ErrorT e m) where
++ pure = return
++ (<*>) = ap -- defined in Control.Monad
++
+ instance Monad m => Monad (ErrorT e m) where
+diff --git a/hs/DBus/Wire/Internal.hs b/hs/DBus/Wire/Internal.hs
+index b386eec..512ff1a 100644
+--- a/hs/DBus/Wire/Internal.hs
++++ b/hs/DBus/Wire/Internal.hs
+@@ -19,3 +19,4 @@
+ module DBus.Wire.Internal where
+-import Control.Monad (liftM, when, unless)
++import Control.Applicative
++import Control.Monad hiding (void)
+
+@@ -96,2 +97,9 @@ newtype Wire s a = Wire
+
++instance Functor (Wire s) where
++ fmap = liftM
++
++instance Applicative (Wire s) where
++ pure = return
++ (<*>) = ap -- defined in Control.Monad
++
+ instance Monad (Wire s) where
diff --git a/dev-haskell/dbus-core/metadata.xml b/dev-haskell/dbus-core/metadata.xml
new file mode 100644
index 000000000000..54fe8f8c3fff
--- /dev/null
+++ b/dev-haskell/dbus-core/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>haskell@gentoo.org</email>
+ <name>Gentoo Haskell</name>
+ </maintainer>
+ <longdescription>
+ Low-level D-Bus protocol implementation
+ </longdescription>
+</pkgmetadata>