summaryrefslogtreecommitdiff
path: root/dev-haskell/cryptonite-conduit/cryptonite-conduit-0.2.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /dev-haskell/cryptonite-conduit/cryptonite-conduit-0.2.2.ebuild
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'dev-haskell/cryptonite-conduit/cryptonite-conduit-0.2.2.ebuild')
-rw-r--r--dev-haskell/cryptonite-conduit/cryptonite-conduit-0.2.2.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-haskell/cryptonite-conduit/cryptonite-conduit-0.2.2.ebuild b/dev-haskell/cryptonite-conduit/cryptonite-conduit-0.2.2.ebuild
new file mode 100644
index 000000000000..c0d2408916c8
--- /dev/null
+++ b/dev-haskell/cryptonite-conduit/cryptonite-conduit-0.2.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+# ebuild generated by hackport 0.5.4
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="cryptonite conduit"
+HOMEPAGE="https://github.com/haskell-crypto/cryptonite-conduit"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RESTRICT=test # test suite fails to build
+
+RDEPEND="dev-haskell/conduit:=[profile?]
+ dev-haskell/conduit-extra:=[profile?]
+ dev-haskell/cryptonite:=[profile?]
+ dev-haskell/exceptions:=[profile?]
+ dev-haskell/memory:=[profile?]
+ dev-haskell/resourcet:=[profile?]
+ >=dev-lang/ghc-7.8.2:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.18.1.3
+ test? ( dev-haskell/conduit-combinators
+ dev-haskell/tasty
+ dev-haskell/tasty-hunit
+ dev-haskell/tasty-quickcheck )
+"