summaryrefslogtreecommitdiff
path: root/dev-haskell/cryptohash-cryptoapi
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-haskell/cryptohash-cryptoapi
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-haskell/cryptohash-cryptoapi')
-rw-r--r--dev-haskell/cryptohash-cryptoapi/Manifest5
-rw-r--r--dev-haskell/cryptohash-cryptoapi/cryptohash-cryptoapi-0.1.3.ebuild28
-rw-r--r--dev-haskell/cryptohash-cryptoapi/cryptohash-cryptoapi-0.1.4.ebuild29
-rw-r--r--dev-haskell/cryptohash-cryptoapi/metadata.xml14
4 files changed, 76 insertions, 0 deletions
diff --git a/dev-haskell/cryptohash-cryptoapi/Manifest b/dev-haskell/cryptohash-cryptoapi/Manifest
new file mode 100644
index 000000000000..62064e6de6c3
--- /dev/null
+++ b/dev-haskell/cryptohash-cryptoapi/Manifest
@@ -0,0 +1,5 @@
+DIST cryptohash-cryptoapi-0.1.3.tar.gz 2922 BLAKE2B bce61995eafdcf5c839cd3f035245cccaf59a676f515836a0afe2862fcc946f1cd143bcb67fd1ceb660d8bcbdecb2791a8190a226dc4c3e9bfc90b936becba6b SHA512 c33af37d4d1d8f3b13ad1ed93db4ec138ea3bef315006ee8117ccacb5c36e2afeb92ae903d46de537f0fbea2a262c5c487eb32d3e1d7099de27b53cc4f17889a
+DIST cryptohash-cryptoapi-0.1.4.tar.gz 3094 BLAKE2B afd5169c172965eadacf9113a03a58cfff9350b63c339170788585437777deb41998322ea3d33f5d9c2c77b4f927e4457bfcaf8f4f92c6f77e85bffc51c02a47 SHA512 f5add1c8922e682d5d08073d0a3d03c6d5545f38edd90821bad7a92f354203ca380ca7e302b4b259bb9e2ce6ae09b1a2428e981e2d745a4a1b1a5cff696621e2
+EBUILD cryptohash-cryptoapi-0.1.3.ebuild 721 BLAKE2B a8cdaac95dd62a2d05cbbfe8c6cd0c7d296a2e8c62d2e92a2a2ef3bd0c83bc747e9983f81779723939baa910289a4be77ff307367dee8f45b2e4f483b295dea2 SHA512 6288cdfc8e87811172ae6d75e4cf82755435b4aee1ff61a1a7f3f214dc1308a80239ed684b314447d8dcdccdedee54ba4078215870b8186a92802321b87ba0ef
+EBUILD cryptohash-cryptoapi-0.1.4.ebuild 754 BLAKE2B cb7574c40fd409f5012d5a6ff350a32712d6cdac66a65470d88b30fcd5af75065fea690b33c2bfd46c27e54b66e111b34739725adb6463e327fba075b07ddc6a SHA512 7953f10ed49c24b5a58e1fd81f5583c81bcf45e398406ade9c208b18c2c4368c614cbbea73cd1ee30f8bbf8297f61f333c6f2ccb6b6b0b10cf1d5999ff0e49a0
+MISC metadata.xml 425 BLAKE2B b7ceac3e2d825beb20a99913efd0924ea410a8db94c5e7f2c8ff90ece0e235cb5a313ef1956b5d0bdc47682f2b09aaf52e7fd365684c8724c8579cef7609fbef SHA512 d02785027a398cb3bff35fadb16316fd642912445872d7d06abfad9cda24da496ddd63bb59054fc21d701b281dd33b1dce961e293041a3435e6bd900191b366a
diff --git a/dev-haskell/cryptohash-cryptoapi/cryptohash-cryptoapi-0.1.3.ebuild b/dev-haskell/cryptohash-cryptoapi/cryptohash-cryptoapi-0.1.3.ebuild
new file mode 100644
index 000000000000..cfb9bf0ecac6
--- /dev/null
+++ b/dev-haskell/cryptohash-cryptoapi/cryptohash-cryptoapi-0.1.3.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Crypto-api interfaces for cryptohash"
+HOMEPAGE="https://github.com/vincenthz/hs-cryptohash-cryptoapi"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/cereal-0.2:=[profile?]
+ >=dev-haskell/crypto-api-0.11:=[profile?]
+ >=dev-haskell/cryptohash-0.8.0:=[profile?]
+ >=dev-haskell/tagged-0.1:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6
+"
diff --git a/dev-haskell/cryptohash-cryptoapi/cryptohash-cryptoapi-0.1.4.ebuild b/dev-haskell/cryptohash-cryptoapi/cryptohash-cryptoapi-0.1.4.ebuild
new file mode 100644
index 000000000000..27bc99ad3a7a
--- /dev/null
+++ b/dev-haskell/cryptohash-cryptoapi/cryptohash-cryptoapi-0.1.4.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.7.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Crypto-api interfaces for cryptohash"
+HOMEPAGE="https://github.com/vincenthz/hs-cryptohash-cryptoapi"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/cereal-0.2:=[profile?]
+ >=dev-haskell/crypto-api-0.11:=[profile?]
+ >=dev-haskell/cryptonite-0.13:=[profile?]
+ dev-haskell/memory:=[profile?]
+ >=dev-haskell/tagged-0.1:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6
+"
diff --git a/dev-haskell/cryptohash-cryptoapi/metadata.xml b/dev-haskell/cryptohash-cryptoapi/metadata.xml
new file mode 100644
index 000000000000..3c253aeae484
--- /dev/null
+++ b/dev-haskell/cryptohash-cryptoapi/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>haskell@gentoo.org</email>
+ <name>Gentoo Haskell</name>
+ </maintainer>
+ <longdescription>
+ Crypto-api interfaces for cryptohash
+ </longdescription>
+ <upstream>
+ <remote-id type="github">vincenthz/hs-cryptohash-cryptoapi</remote-id>
+ </upstream>
+</pkgmetadata>