summaryrefslogtreecommitdiff
path: root/dev-haskell/cryptocipher
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-haskell/cryptocipher
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-haskell/cryptocipher')
-rw-r--r--dev-haskell/cryptocipher/Manifest5
-rw-r--r--dev-haskell/cryptocipher/cryptocipher-0.5.2.ebuild36
-rw-r--r--dev-haskell/cryptocipher/cryptocipher-0.6.2.ebuild30
-rw-r--r--dev-haskell/cryptocipher/metadata.xml14
4 files changed, 85 insertions, 0 deletions
diff --git a/dev-haskell/cryptocipher/Manifest b/dev-haskell/cryptocipher/Manifest
new file mode 100644
index 000000000000..679ea109c8b9
--- /dev/null
+++ b/dev-haskell/cryptocipher/Manifest
@@ -0,0 +1,5 @@
+DIST cryptocipher-0.5.2.tar.gz 22384 BLAKE2B 7133784c97498bbd0c5b39c9bea0e76534c7b3bec26683227277e9ef8474b5cc2cc6e67de46c609b5545a074bae8a3a8401de826b4bb45a30d48df29bf1da4b3 SHA512 f9e76805b27b7002f5393893d9cac30998c82f3d5759be48a25907c95ab0d8250c2e54dea252c1881bca5117fb2fe3fcc59b304265b6db286e1f1a2d733a631d
+DIST cryptocipher-0.6.2.tar.gz 2027 BLAKE2B 617f3c184baa3acb6a248b60dc928fc4696d4818b31a55fe111838154a1f1a6e3fd42c96cb4d8ecceb21ae0145550fe2b097635524207b5d9e63f41e29047d67 SHA512 d63984d26e355ff613a4176c11634f1012f8b9ec43180ffed236f37aa7a1b1dafee1871799eec53774544518c886c27ae19bb0b058288da6bd8f2b45eaa5e5ab
+EBUILD cryptocipher-0.5.2.ebuild 1010 BLAKE2B 6138a4b82f106b9e8a9225da5ab015c7aa7bf41bb8c77dd37b583187f2cb7b2b0bf513c2f7fb69dc967d46cf69b25c83c384aa0be95e6e8b29227af1b54139bb SHA512 424b0e9c4f8487b6e78fd2fba6b15ea1dd119cd0bb64e3d650beb794e23fe3a43c355768d5cb2ece272bb7666e90ce9a1cd63cfa6ac1c3ac8a88baca6f6be498
+EBUILD cryptocipher-0.6.2.ebuild 1090 BLAKE2B d7a9ed16a4c1888f388795e9cd487f3849913eb7e569d09bd7768b49a6e21bad80c4a33e0d5673f5d5145744a9e98255cfa054c2f5e83d88664a172cc5ccdaf8 SHA512 64ada82a43fb68c81c1bb91d74cefa6c326b068ca75c21cf13177337ec9bc6ab19df30d0a9f97826acc97490802e4e64bc89a92cafcd08c6a100527c97cbaf27
+MISC metadata.xml 426 BLAKE2B fb3e13fbea249cd665f5845d33da7c8c25c58d910ba5b585884ad1e64c2e224a5c400bad2ab06af8bd8ac28f57844eef5e69fe0eaffeb1333255d739da2cff5b SHA512 6bec3dd0fb96088e872fa1532d15d910b690c2ea17a9ba4e73047f70c72f1d0c106a8ad78b93c5f298aa7522a62ca6103837160c67d10899b9dee9c0cfc0af1f
diff --git a/dev-haskell/cryptocipher/cryptocipher-0.5.2.ebuild b/dev-haskell/cryptocipher/cryptocipher-0.5.2.ebuild
new file mode 100644
index 000000000000..8e4112ded18c
--- /dev/null
+++ b/dev-haskell/cryptocipher/cryptocipher-0.5.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.3.9999
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Symmetrical block and stream ciphers"
+HOMEPAGE="https://github.com/vincenthz/hs-crypto-cipher"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-haskell/cereal:=[profile?]
+ dev-haskell/cipher-aes:=[profile?]
+ dev-haskell/cipher-rc4:=[profile?]
+ =dev-haskell/cpu-0.1*:=[profile?]
+ >=dev-haskell/crypto-api-0.5:=[profile?]
+ dev-haskell/primitive:=[profile?]
+ >=dev-haskell/vector-0.7:=[profile?]
+ >=dev-lang/ghc-6.10.4:=
+ "
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( dev-haskell/cryptohash
+ dev-haskell/entropy
+ >=dev-haskell/quickcheck-2
+ >=dev-haskell/test-framework-0.3.3
+ >=dev-haskell/test-framework-quickcheck2-0.2.9
+ )"
diff --git a/dev-haskell/cryptocipher/cryptocipher-0.6.2.ebuild b/dev-haskell/cryptocipher/cryptocipher-0.6.2.ebuild
new file mode 100644
index 000000000000..661de1637479
--- /dev/null
+++ b/dev-haskell/cryptocipher/cryptocipher-0.6.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.4.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Symmetrical block and stream ciphers"
+HOMEPAGE="https://github.com/vincenthz/hs-crypto-cipher"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/cipher-aes-0.2.3:=[profile?] <dev-haskell/cipher-aes-0.3:=[profile?]
+ >=dev-haskell/cipher-blowfish-0.0:=[profile?] <dev-haskell/cipher-blowfish-0.1:=[profile?]
+ >=dev-haskell/cipher-camellia-0.0:=[profile?] <dev-haskell/cipher-camellia-0.1:=[profile?]
+ >=dev-haskell/cipher-des-0.0:=[profile?] <dev-haskell/cipher-des-0.1:=[profile?]
+ >=dev-haskell/cipher-rc4-0.1.3:=[profile?] <dev-haskell/cipher-rc4-0.2:=[profile?]
+ >=dev-haskell/crypto-cipher-types-0.0.8:=[profile?] <dev-haskell/crypto-cipher-types-0.1:=[profile?]
+ >=dev-lang/ghc-6.10.4:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+"
diff --git a/dev-haskell/cryptocipher/metadata.xml b/dev-haskell/cryptocipher/metadata.xml
new file mode 100644
index 000000000000..927dcf71828b
--- /dev/null
+++ b/dev-haskell/cryptocipher/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>haskell@gentoo.org</email>
+ <name>Gentoo Haskell</name>
+ </maintainer>
+ <longdescription>
+ Symmetrical Block, Stream and PubKey Ciphers
+ </longdescription>
+ <upstream>
+ <remote-id type="github">vincenthz/hs-crypto-cipher</remote-id>
+ </upstream>
+</pkgmetadata>