summaryrefslogtreecommitdiff
path: root/dev-haskell/crypto-conduit
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-haskell/crypto-conduit
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-haskell/crypto-conduit')
-rw-r--r--dev-haskell/crypto-conduit/Manifest4
-rw-r--r--dev-haskell/crypto-conduit/crypto-conduit-0.5.5-r1.ebuild47
-rw-r--r--dev-haskell/crypto-conduit/crypto-conduit-0.5.5-r2.ebuild48
-rw-r--r--dev-haskell/crypto-conduit/metadata.xml19
4 files changed, 118 insertions, 0 deletions
diff --git a/dev-haskell/crypto-conduit/Manifest b/dev-haskell/crypto-conduit/Manifest
new file mode 100644
index 000000000000..227a059b36b5
--- /dev/null
+++ b/dev-haskell/crypto-conduit/Manifest
@@ -0,0 +1,4 @@
+DIST crypto-conduit-0.5.5.tar.gz 6883 BLAKE2B e0bc6eae04d0da1d0b04135a4d2321a2fc07189010dddfe8d03b161b62d97c631eda0f7f6318b7827a4b6f7fd23d491a13718bddde33d51d8c87baf8f971ba78 SHA512 4fb9df7a5434af1c3bf48e5649b4dc56ee07d03f4f00647adfc61eaf1a0c54326f7374e27717b92106f34435c5ba38eeb7b23082e9095dfbaf131598a8791887
+EBUILD crypto-conduit-0.5.5-r1.ebuild 1387 BLAKE2B c2f321fa9b57ee89223252aba98b63029bde338bdd596b71ac72da67c6ca5bb13dc79c56ea42fde083e67ab584b2570e6563238fb68ed4f5ac922a3bb618b708 SHA512 c078a81c1ac2a2cdf7d7b4665c6e325e64ae4043acbe2be911e2cda295a07b85f25210a1f49b907d36bf33823e3729739ea4a1869b396a1abcf8b3f1b8e51767
+EBUILD crypto-conduit-0.5.5-r2.ebuild 1402 BLAKE2B efcb0836927e77477d2b500ece8c72e659bb80302bc2256fe61d7e0cfbf78f54065eb6fe00dd7bb8585571a60d1acd3e79e8795f2a85d272eb4da0211d1c11f5 SHA512 c54080bafe70b1ed8fef25f7216c806ca238025ac6317cd06cd0911ca29fa740419cb752c8d5aa113f8da2b84e77d5e3ccd90dd0359525c54db9e76b19699ae5
+MISC metadata.xml 616 BLAKE2B cd8021118e67046739cccb77f9779a7231164fcff802bf9d3c9bcb015e1ec4e5055f3c638070fb89c1917a12950312fe511e78a5b3bd35379aebcc558e7b6edf SHA512 5828e9f0d73f84b32017d54be2e231fbfb0b99f4c3e36e1ab91cf1179acdb647273270c15bb00df2009f44f0e3ad6ff62b48601ed4b7133cff40a0ae20181e9d
diff --git a/dev-haskell/crypto-conduit/crypto-conduit-0.5.5-r1.ebuild b/dev-haskell/crypto-conduit/crypto-conduit-0.5.5-r1.ebuild
new file mode 100644
index 000000000000..667fd9ab41c9
--- /dev/null
+++ b/dev-haskell/crypto-conduit/crypto-conduit-0.5.5-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.4.9999
+#hackport: flags: -old-crypto-api
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Conduit interface for cryptographic operations (from crypto-api)"
+HOMEPAGE="https://github.com/prowdsponsor/crypto-conduit"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="+conduit11"
+
+RDEPEND=">=dev-haskell/cereal-0.3:=[profile?]
+ >=dev-haskell/conduit-1.0:=[profile?] <dev-haskell/conduit-1.3:=[profile?]
+ >=dev-haskell/crypto-api-0.9:=[profile?] <dev-haskell/crypto-api-0.14:=[profile?]
+ dev-haskell/resourcet:=[profile?]
+ >=dev-haskell/transformers-0.2:=[profile?] <dev-haskell/transformers-0.5:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+ conduit11? ( >=dev-haskell/conduit-extra-1.1:=[profile?] )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( >=dev-haskell/crypto-api-0.13
+ >=dev-haskell/cryptocipher-0.4
+ >=dev-haskell/cryptohash-cryptoapi-0.1
+ >=dev-haskell/hspec-1.3
+ >=dev-haskell/skein-0.1 )
+"
+
+src_prepare() {
+ cabal_chdeps \
+ 'cereal >= 0.3 && < 0.5' 'cereal >= 0.3'
+}
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag conduit11 conduit11) \
+ --flag=-old-crypto-api
+}
diff --git a/dev-haskell/crypto-conduit/crypto-conduit-0.5.5-r2.ebuild b/dev-haskell/crypto-conduit/crypto-conduit-0.5.5-r2.ebuild
new file mode 100644
index 000000000000..b9f5c4c66071
--- /dev/null
+++ b/dev-haskell/crypto-conduit/crypto-conduit-0.5.5-r2.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.4.9999
+#hackport: flags: -old-crypto-api
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Conduit interface for cryptographic operations (from crypto-api)"
+HOMEPAGE="https://github.com/prowdsponsor/crypto-conduit"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="+conduit11"
+
+RDEPEND=">=dev-haskell/cereal-0.3:=[profile?]
+ >=dev-haskell/conduit-1.0:=[profile?] <dev-haskell/conduit-1.3:=[profile?]
+ >=dev-haskell/crypto-api-0.9:=[profile?] <dev-haskell/crypto-api-0.14:=[profile?]
+ dev-haskell/resourcet:=[profile?]
+ >=dev-haskell/transformers-0.2:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+ conduit11? ( >=dev-haskell/conduit-extra-1.1:=[profile?] )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( >=dev-haskell/crypto-api-0.13
+ >=dev-haskell/cryptocipher-0.4
+ >=dev-haskell/cryptohash-cryptoapi-0.1
+ >=dev-haskell/hspec-1.3
+ >=dev-haskell/skein-0.1 )
+"
+
+src_prepare() {
+ cabal_chdeps \
+ 'cereal >= 0.3 && < 0.5' 'cereal >= 0.3' \
+ 'transformers >= 0.2 && < 0.5' 'transformers >= 0.2'
+}
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag conduit11 conduit11) \
+ --flag=-old-crypto-api
+}
diff --git a/dev-haskell/crypto-conduit/metadata.xml b/dev-haskell/crypto-conduit/metadata.xml
new file mode 100644
index 000000000000..0b8019ffa1d2
--- /dev/null
+++ b/dev-haskell/crypto-conduit/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>haskell@gentoo.org</email>
+ <name>Gentoo Haskell</name>
+ </maintainer>
+ <longdescription>
+ This package contains everything that you need to use a
+ cryptographic package that supports the @crypto-api@ package
+ using conduits from the @conduit@ package.
+ </longdescription>
+ <use>
+ <flag name="conduit11">Use conduit &gt;= 1.1.</flag>
+ </use>
+ <upstream>
+ <remote-id type="github">prowdsponsor/crypto-conduit</remote-id>
+ </upstream>
+</pkgmetadata>