summaryrefslogtreecommitdiff
path: root/dev-haskell/crypto-cipher-tests/crypto-cipher-tests-0.0.11-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-haskell/crypto-cipher-tests/crypto-cipher-tests-0.0.11-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-haskell/crypto-cipher-tests/crypto-cipher-tests-0.0.11-r1.ebuild')
-rw-r--r--dev-haskell/crypto-cipher-tests/crypto-cipher-tests-0.0.11-r1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-haskell/crypto-cipher-tests/crypto-cipher-tests-0.0.11-r1.ebuild b/dev-haskell/crypto-cipher-tests/crypto-cipher-tests-0.0.11-r1.ebuild
new file mode 100644
index 000000000000..eb4193d11bf5
--- /dev/null
+++ b/dev-haskell/crypto-cipher-tests/crypto-cipher-tests-0.0.11-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.4.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Generic cryptography cipher tests"
+HOMEPAGE="https://github.com/vincenthz/hs-crypto-cipher"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/byteable-0.1.1:=[profile?] <dev-haskell/byteable-0.2:=[profile?]
+ >=dev-haskell/crypto-cipher-types-0.0.8:=[profile?] <dev-haskell/crypto-cipher-types-0.1:=[profile?]
+ dev-haskell/hunit:=[profile?]
+ dev-haskell/mtl:=[profile?]
+ >=dev-haskell/quickcheck-2:2=[profile?]
+ >=dev-haskell/securemem-0.1.1:=[profile?] <dev-haskell/securemem-0.2:=[profile?]
+ dev-haskell/test-framework:=[profile?]
+ dev-haskell/test-framework-hunit:=[profile?]
+ dev-haskell/test-framework-quickcheck2:=[profile?]
+ >=dev-lang/ghc-6.10.4:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+"