summaryrefslogtreecommitdiff
path: root/dev-haskell/cpphs/cpphs-1.19.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-haskell/cpphs/cpphs-1.19.3.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-haskell/cpphs/cpphs-1.19.3.ebuild')
-rw-r--r--dev-haskell/cpphs/cpphs-1.19.3.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-haskell/cpphs/cpphs-1.19.3.ebuild b/dev-haskell/cpphs/cpphs-1.19.3.ebuild
new file mode 100644
index 000000000000..976adca5b8ae
--- /dev/null
+++ b/dev-haskell/cpphs/cpphs-1.19.3.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.5.9999
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="A liberalised re-implementation of cpp, the C pre-processor"
+HOMEPAGE="http://projects.haskell.org/cpphs/"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0/${PV}"
+KEYWORDS="~alpha amd64 ~ia64 ~ppc ~ppc64 ~sparc x86"
+IUSE=""
+
+RDEPEND="dev-haskell/old-locale:=[profile?]
+ dev-haskell/old-time:=[profile?]
+ >=dev-haskell/polyparse-1.9:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6
+"
+
+src_prepare() {
+ # https://ghc.haskell.org/trac/ghc/ticket/10667
+ [[ $(ghc-version) == 7.10.1.20150630 ]] && replace-hcflags -g ''
+ [[ $(ghc-version) == 7.10.2 ]] && replace-hcflags -g ''
+}