summaryrefslogtreecommitdiff
path: root/dev-haskell/conduit
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-23 08:35:49 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-23 08:35:49 +0100
commit386855c4d1ef509c1fd32abd721589c81669613b (patch)
tree35dc984118f0a7dc2df88313d83bb5779fd12514 /dev-haskell/conduit
parent0118ac4510d7b85ca62da20e4abd1286dd8bd752 (diff)
gentoo auto-resync : 23:10:2023 - 08:35:49
Diffstat (limited to 'dev-haskell/conduit')
-rw-r--r--dev-haskell/conduit/Manifest4
-rw-r--r--dev-haskell/conduit/conduit-1.3.4.3.ebuild33
-rw-r--r--dev-haskell/conduit/metadata.xml4
3 files changed, 37 insertions, 4 deletions
diff --git a/dev-haskell/conduit/Manifest b/dev-haskell/conduit/Manifest
index 5654fdce521a..c89daf7b3b0f 100644
--- a/dev-haskell/conduit/Manifest
+++ b/dev-haskell/conduit/Manifest
@@ -1,3 +1,5 @@
DIST conduit-1.3.4.2.tar.gz 88962 BLAKE2B 0c4ade4df87c8ace3206e7d4f6b52ae472828f0ad67d5cf970797054f4423c86256c50fdd20f4a7d215b0f1b5ac424ce9431927732c17b1c7c73fd98707e9cfd SHA512 8caf67020e33ddaadc5f05ad3f1aa38d436388f0cb3dac66cb9a645c1693bcd134f1cb8d311eca7b64f9c5ace9ca97681511e5dc28bb70b7b52c43c62d5f3e03
+DIST conduit-1.3.4.3.tar.gz 88820 BLAKE2B af5b1c68c19d1c4428c06e123dc3aec4107dd230e61dae9aa99d96ea448f158136cd4d844edec3e97de65e9093363356b08bb5d4950fdd13393df74e84676063 SHA512 14d4557c1018514da4ae7ae41ec8a381ae57aabd86d84e2c961dce0b784ca4fb8aec5a2757c6fe6d815ce552f25bcc462c208226ca33094e0210b06651846e59
EBUILD conduit-1.3.4.2.ebuild 1090 BLAKE2B 1c3856a1b15b332766571c430e0b00434a5f908e05390165ce36dfa8778c504b4d552de7cda3adff21940220cbf6ea537bf6a8c561be4d326ac304f598e870e0 SHA512 e8c86bde7e60ca9424a4a6bd5a831f663775bc5f4b9001a5dccce5c18e9432837554dab01aa9b6d97fe7c1047e30cc4c64c53f0bb0426fdb18cde42806f72cc5
-MISC metadata.xml 675 BLAKE2B f088af609d60542880063221bdb170aad8f456f1e41b5411354365f53c06cb4f0fbca9a3a390239a7a9b2ba5491fadd27a8147b8d9adcd4a7752febc47531005 SHA512 0d08d0bdd4bb9d302672836538c11df4e4ea166153322744eacd0d06d8f6c8b49371a1617b8d134921a51977de91c4dfde94de0608c64b3ba437a1a59002bc91
+EBUILD conduit-1.3.4.3.ebuild 902 BLAKE2B e2a2eab80f8f82f8e4c9fb61fada5c6931854e64e3c7f9f467f61e5cfe8426c13390ba435f82da09fdbc4153c1914e662835e190a63a08d8c3194b3a445e4d9a SHA512 774c1869dfde4ca318973e0099f3831dab034517772116633a5152b779bc7e59cf645fd3bb43e3f76752f7be09684e7d22e14dd0ebff7bb5a726c7b4cdd3a1ec
+MISC metadata.xml 379 BLAKE2B b9b1d33bc396de42c1c3b3d45a1b6fbc4f25caab17357ae14d88bbb595232b94b08761013f850b496c948b3d59387c2fb3e11ac6a00af0b6c3bb6fbd11b1e1bf SHA512 56d9706cc6ee004c834010a8b3345347f8d0ee23da2200172581b4e584f3442617c601ebbf27283d97ec56f6092e20269d66c095c80197b58a24954c509beef7
diff --git a/dev-haskell/conduit/conduit-1.3.4.3.ebuild b/dev-haskell/conduit/conduit-1.3.4.3.ebuild
new file mode 100644
index 000000000000..be625410fa1d
--- /dev/null
+++ b/dev-haskell/conduit/conduit-1.3.4.3.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.7.3.0
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Streaming data processing library"
+HOMEPAGE="https://github.com/snoyberg/conduit"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+
+RDEPEND=">=dev-haskell/mono-traversable-1.0.7:=[profile?]
+ dev-haskell/primitive:=[profile?]
+ >=dev-haskell/resourcet-1.2:=[profile?] <dev-haskell/resourcet-1.3:=[profile?]
+ dev-haskell/unliftio-core:=[profile?]
+ dev-haskell/vector:=[profile?]
+ >=dev-lang/ghc-8.10.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-3.2.0.0
+ test? ( >=dev-haskell/hspec-1.3
+ >=dev-haskell/quickcheck-2.7
+ dev-haskell/safe
+ dev-haskell/silently
+ >=dev-haskell/split-0.2.0.0
+ >=dev-haskell/unliftio-0.2.4.0 )
+"
diff --git a/dev-haskell/conduit/metadata.xml b/dev-haskell/conduit/metadata.xml
index 119586ddfe53..9d00781cb34b 100644
--- a/dev-haskell/conduit/metadata.xml
+++ b/dev-haskell/conduit/metadata.xml
@@ -5,10 +5,8 @@
<email>haskell@gentoo.org</email>
<name>Gentoo Haskell</name>
</maintainer>
- <longdescription>
- Conduits are an approach to the streaming data problem. It is meant as an alternative to enumerators\/iterators, hoping to address the same issues with different trade-offs based on real-world experience with enumerators. For more information, see &lt;http://www.yesodweb.com/blog/2011/12/conduits&gt;.
- </longdescription>
<upstream>
+ <remote-id type="hackage">conduit</remote-id>
<remote-id type="github">snoyberg/conduit</remote-id>
</upstream>
</pkgmetadata>