summaryrefslogtreecommitdiff
path: root/dev-haskell/conduit-extra/conduit-extra-1.1.13.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-haskell/conduit-extra/conduit-extra-1.1.13.1.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-haskell/conduit-extra/conduit-extra-1.1.13.1.ebuild')
-rw-r--r--dev-haskell/conduit-extra/conduit-extra-1.1.13.1.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-haskell/conduit-extra/conduit-extra-1.1.13.1.ebuild b/dev-haskell/conduit-extra/conduit-extra-1.1.13.1.ebuild
new file mode 100644
index 000000000000..4b1d1d377632
--- /dev/null
+++ b/dev-haskell/conduit-extra/conduit-extra-1.1.13.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.7.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Batteries included conduit: adapters for common libraries"
+HOMEPAGE="https://github.com/snoyberg/conduit"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-haskell/async:=[profile?]
+ >=dev-haskell/attoparsec-0.10:=[profile?]
+ >=dev-haskell/blaze-builder-0.3:=[profile?]
+ >=dev-haskell/conduit-1.1:=[profile?] <dev-haskell/conduit-1.3:=[profile?]
+ dev-haskell/exceptions:=[profile?]
+ dev-haskell/monad-control:=[profile?]
+ >=dev-haskell/network-2.3:=[profile?]
+ >=dev-haskell/primitive-0.5:=[profile?]
+ >=dev-haskell/resourcet-1.1:=[profile?]
+ dev-haskell/stm:=[profile?]
+ >=dev-haskell/streaming-commons-0.1.11:=[profile?]
+ dev-haskell/text:=[profile?]
+ dev-haskell/transformers:=[profile?]
+ dev-haskell/transformers-base:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( dev-haskell/bytestring-builder
+ >=dev-haskell/hspec-1.3
+ dev-haskell/quickcheck )
+"