summaryrefslogtreecommitdiff
path: root/dev-haskell/cmdargs
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-23 08:35:49 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-23 08:35:49 +0100
commit386855c4d1ef509c1fd32abd721589c81669613b (patch)
tree35dc984118f0a7dc2df88313d83bb5779fd12514 /dev-haskell/cmdargs
parent0118ac4510d7b85ca62da20e4abd1286dd8bd752 (diff)
gentoo auto-resync : 23:10:2023 - 08:35:49
Diffstat (limited to 'dev-haskell/cmdargs')
-rw-r--r--dev-haskell/cmdargs/Manifest4
-rw-r--r--dev-haskell/cmdargs/cmdargs-0.10.22.ebuild36
-rw-r--r--dev-haskell/cmdargs/metadata.xml24
3 files changed, 42 insertions, 22 deletions
diff --git a/dev-haskell/cmdargs/Manifest b/dev-haskell/cmdargs/Manifest
index afdef67d9d01..13077c6915ee 100644
--- a/dev-haskell/cmdargs/Manifest
+++ b/dev-haskell/cmdargs/Manifest
@@ -1,3 +1,5 @@
DIST cmdargs-0.10.20.tar.gz 64550 BLAKE2B 08511df092c2a7010af94bc8d9b54b29c0e76c33be06a9521eccc85092b57a45ae9f9d22b0f8e81266073c81185b66266d1f2321c327ae730c6ccebea7f6d6cf SHA512 b9e270aa5dabd84eaaa47b95a450ef5b5f43cd19646f2a407579f855857d396e5ab9ca0038e1e876849a596ecb8cdc9964c45970825a0a95021d69b23699da79
+DIST cmdargs-0.10.22.tar.gz 65154 BLAKE2B a6f05c4a186dc4dbb9de3c754f9100138d3954b1537b1ecb81e2fec2c6bd293dd381a2a666dae0bcbbc631e9ab95d8a65d85d68d3e2c80bb2d6ad87baf9906b1 SHA512 571d9584769fdb5bb77a57607c2f432b365604a2ca2e9b5c044c319499004f7fcb12f2f6e61091a245f1bf6a5d321d38ade1a54d5bc86831136fa85b9b898faa
EBUILD cmdargs-0.10.20.ebuild 746 BLAKE2B de6e7bbb61af70b7871376c8be1db956b59f0346ed2dd6a346b040b0b218c1e1bc77d68cb1923d2dd17db2e57e1cf033a3c21fe5c44e244cb7dbab6ad673e437 SHA512 712b79dc1e5eb50588fb57fe81a68e4f4aa7164504411914d0451c8f7b4feba3c612b69a470f4b39d24026d7192d929cf93c8ed50a3e687ca821fb4d4d3d2629
-MISC metadata.xml 1400 BLAKE2B a74a9c6167705668afeee2cd4a7a49ddff949f15e81bc3dcb459e0d5b414696861e8ebaaf147fb894df9c956c40019e7a5ad76c1d2ac3555804ad968ad819193 SHA512 1ee1a902859075b5beefd7f7be2e0fca32791f613f3236f78c5bbc0b5e67b6fe04a73a55ea9b00270667fffa1ed1b531089169042b4bb7a4fa975bab9fed6a56
+EBUILD cmdargs-0.10.22.ebuild 790 BLAKE2B fa24d16abde759f76190f7c8cd75b61e54a5531454b84c9affbcc0d76c416573cc36e30d852c4cc5c83d18cdeec96ef9cfb70ee3145b228cc04be741bec9ccd7 SHA512 f99dde16cfb092c4cc50d6354cdaaea7dc7ff09a9fa36f7e78c77749424086a489284705f63c5545d48dde591d64466780f06a9b292c3ec7d79c1af3c193b017
+MISC metadata.xml 567 BLAKE2B 8870aad0f3b257d8b85d60ad55a9bf35a0f358387de6b3d97cfa78a5e10964c0a6fe6158427af6945170bbe5ce0bafdecde191caa0a5b67ca03357964103945b SHA512 d6de3cc99bd65b87e02c7b46111349673026664b63e60bfa8fc35370bbe612544e6a30e8f7eadcea7098635ec0fcf52239e996bedd553a50ea086b9739c560ee
diff --git a/dev-haskell/cmdargs/cmdargs-0.10.22.ebuild b/dev-haskell/cmdargs/cmdargs-0.10.22.ebuild
new file mode 100644
index 000000000000..2ce0041ab470
--- /dev/null
+++ b/dev-haskell/cmdargs/cmdargs-0.10.22.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.8.4.0.9999
+#hackport: flags: testprog:examples
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Command line argument processing"
+HOMEPAGE="https://github.com/ndmitchell/cmdargs#readme"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+IUSE="examples +quotation"
+REQUIRED_USE="examples? ( quotation )"
+
+CABAL_CHDEPS=(
+ 'executable cmdargs' 'executable cmdargs-demo'
+)
+
+RDEPEND="
+ >=dev-lang/ghc-8.8.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-3.0.0.0
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag quotation quotation) \
+ $(cabal_flag examples testprog)
+}
diff --git a/dev-haskell/cmdargs/metadata.xml b/dev-haskell/cmdargs/metadata.xml
index 4ba506a01472..4a2ade06e3ba 100644
--- a/dev-haskell/cmdargs/metadata.xml
+++ b/dev-haskell/cmdargs/metadata.xml
@@ -5,31 +5,13 @@
<email>haskell@gentoo.org</email>
<name>Gentoo Haskell</name>
</maintainer>
- <longdescription>
- This library provides an easy way to define command line parsers. Most users
- will want to use the "System.Console.CmdArgs.Implicit" module, whose
- documentation contains an example.
-
- * "System.Console.CmdArgs.Explicit" provides a way to write command line
- parsers for both single mode programs (most programs) and multiple
- mode programs (e.g. darcs or cabal). Parsers are defined by constructing
- a data structure.
-
- * "System.Console.CmdArgs.Implicit" provides a way to concisely define
- command line parsers, up to three times shorter than getopt. These parsers
- are translated into the Explicit data type.
-
- * "System.Console.CmdArgs.GetOpt" provides a wrapper allowing compatiblity
- with existing getopt parsers, mapping to the Explicit data type.
-
- For a general reference on what command line flags are commonly used,
- see &lt;http://www.faqs.org/docs/artu/ch10s05.html&gt;.
- </longdescription>
<use>
+ <flag name="examples">Build the cmdargs-demo program</flag>
<flag name="testprog">Build the test program</flag>
- <flag name="quotation">Build quote module</flag>
+ <flag name="quotation">Build the Quote module</flag>
</use>
<upstream>
+ <remote-id type="hackage">cmdargs</remote-id>
<remote-id type="github">ndmitchell/cmdargs</remote-id>
</upstream>
</pkgmetadata>