summaryrefslogtreecommitdiff
path: root/dev-haskell/c2hs/c2hs-0.16.5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-haskell/c2hs/c2hs-0.16.5.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-haskell/c2hs/c2hs-0.16.5.ebuild')
-rw-r--r--dev-haskell/c2hs/c2hs-0.16.5.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/dev-haskell/c2hs/c2hs-0.16.5.ebuild b/dev-haskell/c2hs/c2hs-0.16.5.ebuild
new file mode 100644
index 000000000000..881f9ea1e06f
--- /dev/null
+++ b/dev-haskell/c2hs/c2hs-0.16.5.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.9999
+
+CABAL_FEATURES="bin"
+inherit haskell-cabal
+
+DESCRIPTION="C->Haskell FFI tool that gives some cross-language type safety"
+HOMEPAGE="http://www.cse.unsw.edu.au/~chak/haskell/c2hs/"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~ia64 ~ppc ~ppc64 ~sparc x86"
+IUSE="doc"
+
+DEPEND=">=dev-lang/ghc-6.10.4
+ >=dev-haskell/cabal-1.6
+ >=dev-haskell/language-c-0.3.1.1
+ <dev-haskell/language-c-0.5
+ doc? ( ~app-text/docbook-xml-dtd-4.2
+ app-text/docbook-xsl-stylesheets
+ >=dev-libs/libxslt-1.1.2 )"
+RDEPEND="dev-libs/gmp"
+
+src_compile() {
+ cabal_src_compile
+
+ if use doc; then
+ emake -C doc
+ fi
+}
+
+src_install() {
+ cabal_src_install
+
+ doman "${S}/doc/man1/c2hs.1"
+
+ if use doc; then
+ dohtml "${S}/doc/users_guide/"*
+ fi
+}