summaryrefslogtreecommitdiff
path: root/dev-haskell/bytestring-show
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-haskell/bytestring-show
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-haskell/bytestring-show')
-rw-r--r--dev-haskell/bytestring-show/Manifest4
-rw-r--r--dev-haskell/bytestring-show/bytestring-show-0.3.5.6-r1.ebuild30
-rw-r--r--dev-haskell/bytestring-show/bytestring-show-0.3.5.6.ebuild25
-rw-r--r--dev-haskell/bytestring-show/metadata.xml11
4 files changed, 70 insertions, 0 deletions
diff --git a/dev-haskell/bytestring-show/Manifest b/dev-haskell/bytestring-show/Manifest
new file mode 100644
index 000000000000..c51b51ab5e02
--- /dev/null
+++ b/dev-haskell/bytestring-show/Manifest
@@ -0,0 +1,4 @@
+DIST bytestring-show-0.3.5.6.tar.gz 8145 BLAKE2B 421a6593e77f200db1f905a5e74071116327dd018fc8117c5c81fe0193891070f3b190b4d7ffd2e056ba4b1adb9e8eae87e2f905036a0f85ab94ab7d03602d05 SHA512 f59a041e30ec3b3eb9f971968606685ba5968dafc44d92ed50c9f7f124b891f48fc6612fdfc1a57f702e76e41f70c647e81c1919ab7fee194db9d97ddd73dd10
+EBUILD bytestring-show-0.3.5.6-r1.ebuild 658 BLAKE2B a11f560a0caabd5a7e64c77ee80f6c1c869afff035d1bb65d1a073e48d64b85d1daa1563a7562aa133c4a49b9fa1739859298bc1a366f08a6f72ac46557b4b0e SHA512 8c6e8e78bba4acb0948091cf79a8d4f2b4dcb3c6ea5316a458fa38fd835d4565a932d92d275bfed211edfae7976e3a894a1bb0d137a7270d83388b475e348eb3
+EBUILD bytestring-show-0.3.5.6.ebuild 602 BLAKE2B abb8a08185645243d4255cd5acb458e8bffef782262cad90aaae679736c5825dabbe9186797d0057df845147a90c465997854779ae055e9b434b40c6d2a37e3b SHA512 35bb225439830bae52e8cbab50ff923d21f7822872327519a588c55ad45908eb624900aceaff14561f9652c4eae3ffc57a4c0941eb04e1eed4a682cb592a124a
+MISC metadata.xml 349 BLAKE2B 504fc652944adae9b0c8fb5bcdc05e0fdbb148769fe6b60ced95fc64fdb444591e0793ab553b7c11be7b7b7e71b6390377b5a892ae2888fd387d67e0a7a1000a SHA512 36b8864806915993dd6018b5118cb5299860ee5110f3740ae204db2c5a7d0c0a708b1f9e4db1d4ae8bbe5a0c6f8f9ce28907ef6b4b534ada8690b2a36eb0165f
diff --git a/dev-haskell/bytestring-show/bytestring-show-0.3.5.6-r1.ebuild b/dev-haskell/bytestring-show/bytestring-show-0.3.5.6-r1.ebuild
new file mode 100644
index 000000000000..a19bb794d4c7
--- /dev/null
+++ b/dev-haskell/bytestring-show/bytestring-show-0.3.5.6-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.6.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Efficient conversion of values into readable byte strings"
+HOMEPAGE="http://code.haskell.org/~dolio/"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-haskell/binary:=[profile?]
+ >=dev-lang/ghc-6.10.4:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6.0.3
+"
+
+src_prepare() {
+ cabal_chdeps \
+ 'binary < 0.8' 'binary'
+}
diff --git a/dev-haskell/bytestring-show/bytestring-show-0.3.5.6.ebuild b/dev-haskell/bytestring-show/bytestring-show-0.3.5.6.ebuild
new file mode 100644
index 000000000000..f39671a4096c
--- /dev/null
+++ b/dev-haskell/bytestring-show/bytestring-show-0.3.5.6.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.6.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Efficient conversion of values into readable byte strings"
+HOMEPAGE="http://code.haskell.org/~dolio/"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="<dev-haskell/binary-0.8:=[profile?]
+ >=dev-lang/ghc-6.10.4:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6.0.3
+"
diff --git a/dev-haskell/bytestring-show/metadata.xml b/dev-haskell/bytestring-show/metadata.xml
new file mode 100644
index 000000000000..60a115dcf1b6
--- /dev/null
+++ b/dev-haskell/bytestring-show/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>haskell@gentoo.org</email>
+ <name>Gentoo Haskell</name>
+ </maintainer>
+ <longdescription>
+ Efficient conversion of values into readable byte strings.
+ </longdescription>
+</pkgmetadata>