summaryrefslogtreecommitdiff
path: root/dev-haskell/bytes
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-haskell/bytes
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-haskell/bytes')
-rw-r--r--dev-haskell/bytes/Manifest3
-rw-r--r--dev-haskell/bytes/bytes-0.15.2.ebuild42
-rw-r--r--dev-haskell/bytes/metadata.xml17
3 files changed, 62 insertions, 0 deletions
diff --git a/dev-haskell/bytes/Manifest b/dev-haskell/bytes/Manifest
new file mode 100644
index 000000000000..664481681651
--- /dev/null
+++ b/dev-haskell/bytes/Manifest
@@ -0,0 +1,3 @@
+DIST bytes-0.15.2.tar.gz 18834 BLAKE2B 18f0e2618a3ed7f4eefaabd0c4b4ca6b99e4493ae0b73dee9a7f0fe1c2e980a4e8714e50198177a657d6ac06c08227350dc342178f5565444ea9f23904d01585 SHA512 339da2fe49a6acd307057bfcc79e7ac09eefb9a93ec60cd52a8d425337e7bf355ca8aa42f304863df773b0ef2c459b53571920611cf1ef8f98e78d112cc6ad29
+EBUILD bytes-0.15.2.ebuild 1597 BLAKE2B 4496f10bb4c1c1ea5be4e9e7a11a447466711d82a2141e452c6909c4653ba87e615f17c99e83b7be1a0b01bd577925eb4915bd917d9ac534b71c44948c2c683b SHA512 105278f6df611871326d38e7cbd0d0f54c824c21e59ca7959c7bc7e510a0fd8ec1bc2169d5ffdafdcc3e1cd31bb27d16b61e4f746e5574bfd6f5472e069cd96e
+MISC metadata.xml 546 BLAKE2B cad0bd3e287b2b7837e477aefdd4a2e7fec6acc0ac4c9be876a089f48c31bd507c5fa6a037289153774b1d55adaff81926327e1ce6001dc5bb0ca790228a211a SHA512 1f54179d87820c310fb26f4b168bcb2cfbc5d668d6893867e19015a8def8afb08d6f40482b27237a858e80d6252ad793230e43a467a84d9ae8e87501b4acdca7
diff --git a/dev-haskell/bytes/bytes-0.15.2.ebuild b/dev-haskell/bytes/bytes-0.15.2.ebuild
new file mode 100644
index 000000000000..7a476dc94709
--- /dev/null
+++ b/dev-haskell/bytes/bytes-0.15.2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.6.9999
+#hackport: flags: -lib-werror
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Sharing code for serialization between binary and cereal"
+HOMEPAGE="https://github.com/ekmett/bytes"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="+test-doctests"
+
+RDEPEND=">=dev-haskell/binary-0.5.1:=[profile?] <dev-haskell/binary-0.9:=[profile?]
+ >=dev-haskell/cereal-0.3.5:=[profile?] <dev-haskell/cereal-0.6:=[profile?]
+ >=dev-haskell/hashable-1.0.1.1:=[profile?] <dev-haskell/hashable-1.4:=[profile?]
+ >=dev-haskell/mtl-2.0:=[profile?] <dev-haskell/mtl-2.3:=[profile?]
+ >=dev-haskell/scientific-0.0:=[profile?] <dev-haskell/scientific-1:=[profile?]
+ >=dev-haskell/text-0.2:=[profile?] <dev-haskell/text-1.3:=[profile?]
+ >=dev-haskell/transformers-0.2:=[profile?] <dev-haskell/transformers-0.6:=[profile?]
+ >=dev-haskell/transformers-compat-0.3:=[profile?] <dev-haskell/transformers-compat-1:=[profile?]
+ >=dev-haskell/unordered-containers-0.2:=[profile?] <dev-haskell/unordered-containers-0.3:=[profile?]
+ >=dev-haskell/void-0.6:=[profile?] <dev-haskell/void-1:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( test-doctests? ( >=dev-haskell/doctest-0.9.1 ) )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=-lib-werror \
+ $(cabal_flag test-doctests test-doctests)
+}
diff --git a/dev-haskell/bytes/metadata.xml b/dev-haskell/bytes/metadata.xml
new file mode 100644
index 000000000000..d66a19bf4f83
--- /dev/null
+++ b/dev-haskell/bytes/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>haskell@gentoo.org</email>
+ <name>Gentoo Haskell</name>
+ </maintainer>
+ <use>
+ <flag name="test-doctests">Enable the doctest suite when using the enable-tests option for cabal.</flag>
+ </use>
+ <longdescription>
+ Sharing code for serialization between binary and cereal
+ </longdescription>
+ <upstream>
+ <remote-id type="github">ekmett/bytes</remote-id>
+ </upstream>
+</pkgmetadata>