summaryrefslogtreecommitdiff
path: root/dev-haskell/biosff
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-haskell/biosff
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-haskell/biosff')
-rw-r--r--dev-haskell/biosff/Manifest4
-rw-r--r--dev-haskell/biosff/biosff-0.3.7.1.ebuild39
-rw-r--r--dev-haskell/biosff/files/biosff-0.3.7.1-ghc-7.10.patch7
-rw-r--r--dev-haskell/biosff/metadata.xml18
4 files changed, 68 insertions, 0 deletions
diff --git a/dev-haskell/biosff/Manifest b/dev-haskell/biosff/Manifest
new file mode 100644
index 000000000000..71e95573583e
--- /dev/null
+++ b/dev-haskell/biosff/Manifest
@@ -0,0 +1,4 @@
+AUX biosff-0.3.7.1-ghc-7.10.patch 214 BLAKE2B aeae844af1b934653223812838a01f6abb3b664d07e6abdf820e37c791b95d8020815744cac094a9ce2e9ce1c1133bf4439b0b903a54de02ec43e7666f87c455 SHA512 44d1f85fb4625114cf1d032a9f16b57a1602489100521e2801bc8aaa42b5bf6990fa3b849fe040f13ff19a13a0cde13ccc3965826d9673a191f4356d8c0cd96f
+DIST biosff-0.3.7.1.tar.gz 26705 BLAKE2B abf585342c14c01a8f202b34ec94e67138e345918b43a52dbf535c3690bca2039c977ee36ebef861d5f215174429f41702e84d440cf52316de0ec82722053f72 SHA512 ce075d734864b9a00999d5c37c824ece5ba475b583536eb842835b4a44ff56581f18ba8ddf065f2ea4416ff4f96279f6a46f5e57330a43d40164f4cabab2ab9f
+EBUILD biosff-0.3.7.1.ebuild 923 BLAKE2B d071ed43396e80ea08e73b4510bfcfdbbac8c0c5793831d801d3cc043ad2aac5fdfe84d239bf554bc34fdb9f34aec16a089e24f97fa42314736aa0f4823d19c1 SHA512 0089ac4b6ab86ed1d860a1b8885970d917e9b413d60d8b621931313030d4285e55ea420b70183e4d8216162ae3c5ff63f581f6cc7790f1d59c6a3f97be918b2b
+MISC metadata.xml 673 BLAKE2B 4235ed5755c459eaf862037e9f802efb13ffdbc6180bce6747ea6b8e899880549d262596bd8c94bd862667cbf1748c3ed1e47db760e5e9a55c4606c483dd8d19 SHA512 b344429da849558e9e0ae5814111e1fd1add4a4b0548eeb358aaa220ede1ac2dc284378b87ebc8c747c0d8dcbabb05d8d9e00c2bd5b3a2faccdfc7f5c625ff47
diff --git a/dev-haskell/biosff/biosff-0.3.7.1.ebuild b/dev-haskell/biosff/biosff-0.3.7.1.ebuild
new file mode 100644
index 000000000000..3dd0b8133975
--- /dev/null
+++ b/dev-haskell/biosff/biosff-0.3.7.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.4.9999
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Library and executables for working with SFF files"
+HOMEPAGE="http://biohaskell.org/"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="+fclip +flower +frecover"
+
+RDEPEND="dev-haskell/binary:=[profile?]
+ >=dev-haskell/biocore-0.3:=[profile?]
+ dev-haskell/cmdargs:=[profile?]
+ >=dev-haskell/mtl-2:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6
+"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-ghc-7.10.patch
+}
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag fclip fclip) \
+ $(cabal_flag flower flower) \
+ $(cabal_flag frecover frecover)
+}
diff --git a/dev-haskell/biosff/files/biosff-0.3.7.1-ghc-7.10.patch b/dev-haskell/biosff/files/biosff-0.3.7.1-ghc-7.10.patch
new file mode 100644
index 000000000000..48c29358ca7c
--- /dev/null
+++ b/dev-haskell/biosff/files/biosff-0.3.7.1-ghc-7.10.patch
@@ -0,0 +1,7 @@
+diff --git a/src/Flower/Main.hs b/src/Flower/Main.hs
+index b0cbd1c..3428db5 100644
+--- a/src/Flower/Main.hs
++++ b/src/Flower/Main.hs
+@@ -1 +1,2 @@
++{-# LANGUAGE FlexibleContexts #-}
+ -- FlowEr - FLOWgram ExtractoR
diff --git a/dev-haskell/biosff/metadata.xml b/dev-haskell/biosff/metadata.xml
new file mode 100644
index 000000000000..d5fd876231a8
--- /dev/null
+++ b/dev-haskell/biosff/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>haskell@gentoo.org</email>
+ <name>Gentoo Haskell</name>
+ </maintainer>
+ <longdescription>
+ The library contains the functionality for reading and writing
+ SFF files (sequencing data from 454 and Ion Torrent). It duplicates
+ code from (and is incompatible with) the "bio" library.
+ </longdescription>
+ <use>
+ <flag name="fclip">Build the fclip executable.</flag>
+ <flag name="flower">Build the flower executable.</flag>
+ <flag name="frecover">Build the frecover executable.</flag>
+ </use>
+</pkgmetadata>