summaryrefslogtreecommitdiff
path: root/dev-haskell/bio
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-haskell/bio
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-haskell/bio')
-rw-r--r--dev-haskell/bio/Manifest4
-rw-r--r--dev-haskell/bio/bio-0.5.3-r2.ebuild63
-rw-r--r--dev-haskell/bio/files/bio-0.5.3-ghc-7.10.patch7
-rw-r--r--dev-haskell/bio/metadata.xml25
4 files changed, 99 insertions, 0 deletions
diff --git a/dev-haskell/bio/Manifest b/dev-haskell/bio/Manifest
new file mode 100644
index 000000000000..09849c9c8fd8
--- /dev/null
+++ b/dev-haskell/bio/Manifest
@@ -0,0 +1,4 @@
+AUX bio-0.5.3-ghc-7.10.patch 266 BLAKE2B 2db06eaf40ef90741aca5c329e096a82f259c5c068728338d798ba083ab7cd194f95cb54d0b2eee1257b15b8cce534a270adfd4b01b21ecab7245eb88b5b1bb5 SHA512 58efe74d17f2233f43c43d56eaabb849bc7753e27b3499544856036984504add5a50f4d6e1cf43af64a19695c1ef44cdd82514ce5126d50815b659e20bd93785
+DIST bio-0.5.3.tar.gz 103707 BLAKE2B 31c9e354ba33f20d6129a20d6272063498bfd4b4ea2cba9eddab8ede62ee894659eb5e6383ef022f5e003deab8bb3c92a98bcadae44db22e7b0346471cad5e4d SHA512 fbe09240a600abbcac952f52f05f28f9b305a1ae3def8b4144bd73bdb160acfbe5457086ef829057d5a73df1df5061668487b2ca5621df73628c8c4990b6b544
+EBUILD bio-0.5.3-r2.ebuild 1404 BLAKE2B 434ee9037af79c29b9d4097a0eb34813187bd111e17619d4527959fc0fe4b4ff6008480d46801963c12cfc4db71a81fc9b8454f174f6cef8062e04ceb9f0a45f SHA512 14e47edc973b6fec1b552158be098e7349e35d9ed9285a3cec7d9a3e207bddf8c50adb9ce27e66330d04119adcd10f1045ae961787184e8678db71b83e757933
+MISC metadata.xml 1145 BLAKE2B 1b90a811913c7c6247ca1e2237a8d0ea8e0bd56f7e3310a5e61df90d6dadc365ed4a5c58829a94efe61f88c57270e7c715989f5b0ff02ad75395703e2d7bd596 SHA512 c91ebcc3b83ab7d9bbcaee0cff08cf212b3d77b1d2a34c70308d7bb3ff47f898668c1cb13c2e761ce25653bf167bce55fa9dd848d52e6ffd8e93021e173e8e7f
diff --git a/dev-haskell/bio/bio-0.5.3-r2.ebuild b/dev-haskell/bio/bio-0.5.3-r2.ebuild
new file mode 100644
index 000000000000..c2d94eaad256
--- /dev/null
+++ b/dev-haskell/bio/bio-0.5.3-r2.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.2.9999
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour"
+inherit eutils haskell-cabal
+
+DESCRIPTION="A bioinformatics library"
+HOMEPAGE="http://biohaskell.org/Libraries/Bio"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="+examples test"
+
+RDEPEND=">=dev-haskell/binary-0.4:=[profile?]
+ dev-haskell/mtl:=[profile?]
+ dev-haskell/old-time:=[profile?]
+ dev-haskell/parallel:=[profile?]
+ dev-haskell/parsec:=[profile?]
+ >=dev-haskell/quickcheck-2:2=[profile?]
+ dev-haskell/random:=[profile?]
+ >=dev-haskell/tagsoup-0.8:=[profile?]
+ >=dev-lang/ghc-6.10.4:="
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-ghc-7.10.patch
+
+ cabal_chdeps \
+ 'binary >=0.4 && <0.5' 'binary >=0.4'
+}
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag examples examples) \
+ $(cabal_flag test test)
+}
+
+src_test() {
+ dist/build/qc/qc || die
+}
+
+src_install() {
+ haskell-cabal_src_install
+
+ use test && rm "${ED}"/usr/bin/qc
+ # many examples collide with dev-haskell/flower
+ if use examples ; then
+ pushd "${ED}"/usr/bin
+ local example
+ for example in *
+ do
+ mv "${example}" "${PN}-example-${example}"
+ done
+ popd
+ fi
+}
diff --git a/dev-haskell/bio/files/bio-0.5.3-ghc-7.10.patch b/dev-haskell/bio/files/bio-0.5.3-ghc-7.10.patch
new file mode 100644
index 000000000000..d570d22917a7
--- /dev/null
+++ b/dev-haskell/bio/files/bio-0.5.3-ghc-7.10.patch
@@ -0,0 +1,7 @@
+diff --git a/Bio/Alignment/Bowtie.hs b/Bio/Alignment/Bowtie.hs
+index 883b057..3e58f0e 100644
+--- a/Bio/Alignment/Bowtie.hs
++++ b/Bio/Alignment/Bowtie.hs
+@@ -1 +1,2 @@
++{-# LANGUAGE FlexibleContexts #-}
+ {-| This module provides a data type to represent an alignment
diff --git a/dev-haskell/bio/metadata.xml b/dev-haskell/bio/metadata.xml
new file mode 100644
index 000000000000..8927e5f99073
--- /dev/null
+++ b/dev-haskell/bio/metadata.xml
@@ -0,0 +1,25 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>haskell@gentoo.org</email>
+ <name>Gentoo Haskell</name>
+ </maintainer>
+ <longdescription>
+ This is a collection of data structures and algorithms
+ useful for building bioinformatics-related tools
+ and utilities.
+
+ Current list of features includes: a Sequence data type supporting
+ protein and nucleotide sequences and conversion between them. As of version
+ 0.4, different kinds of sequence have different types. Support for quality
+ data, reading and writing Fasta formatted files, reading TwoBit and
+ phd formats, and Roche/454 SFF files. Rudimentary (i.e. unoptimized) support
+ for doing alignments - including dynamic adjustment of scores based on sequence quality.
+ Also Blast output parsing. Partly implemented single linkage clustering, and
+ multiple alignment. Reading Gene Ontology (GO) annotations (GOA) and
+ definitions\/hierarchy.
+
+ The Darcs repository is at: &lt;http://malde.org/~ketil/biohaskell/biolib&gt;.
+ </longdescription>
+</pkgmetadata>