summaryrefslogtreecommitdiff
path: root/dev-haskell/binary-orphans
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-haskell/binary-orphans
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-haskell/binary-orphans')
-rw-r--r--dev-haskell/binary-orphans/Manifest3
-rw-r--r--dev-haskell/binary-orphans/binary-orphans-0.1.6.0-r1.ebuild48
-rw-r--r--dev-haskell/binary-orphans/metadata.xml11
3 files changed, 62 insertions, 0 deletions
diff --git a/dev-haskell/binary-orphans/Manifest b/dev-haskell/binary-orphans/Manifest
new file mode 100644
index 000000000000..e517eea87418
--- /dev/null
+++ b/dev-haskell/binary-orphans/Manifest
@@ -0,0 +1,3 @@
+DIST binary-orphans-0.1.6.0.tar.gz 5320 SHA256 e0e1dc7e5f00feb225efde400988d5e0e199cc910446f05a40fecba7d55684a5 SHA512 646410b79d92a20ef7b6d6583fca38da672e7fe072d2d5a7a9d50bacd1fb3da20efd9ab42e74029279dcd5a2c4b80218b860ae8e45bef348a692b23bcc8ea351 WHIRLPOOL 35b7f84e08f5fd643082764a096ccd7945d9ef28287d58b975f11b3191851442af2eceb109531249a31ee3e39266c59901370eb9e81e5786636cabd69dcc1910
+EBUILD binary-orphans-0.1.6.0-r1.ebuild 2046 SHA256 152273f17aa8fd5c4ab3933e0161ad13db8be5d4806345be45aaa29565bb2a8d SHA512 0626c811c11ae897901d43d06729cd7a03b849328c2a5b7762abebde6ff173062ca746e09f227455be28dfd80026629cea238b2c60634e5b569679a16f246529 WHIRLPOOL 58aedbe8616daf34d39b8596d315f5bd9627b16557ec05b829274367d82e06a7dc75b07baf61c86fe38488993ddcc0c929f4732712b2ce18e419e9750a47c84b
+MISC metadata.xml 368 SHA256 917f2f63a2d4f82c7ab0dab648945cf9812d6743ba38fd86773305efcfefe6bd SHA512 e5dc324c3ec28d21fa959b06947784d263dff0b6a7094ea1a19ef477cf235aa5b2655d72ce3c6ea87fa9e2f429f2e9a80858ca8fc8d61b5e263cb9bb13f7180a WHIRLPOOL c35ffbefc1a6ddb8ef3a5de7cdee25d193b90bc32ebdb465ae470109d7e31424b4fd36a7b12d9ad8d6ad493c217af3b0b02dc7238673a208bcaf8035b4517e3a
diff --git a/dev-haskell/binary-orphans/binary-orphans-0.1.6.0-r1.ebuild b/dev-haskell/binary-orphans/binary-orphans-0.1.6.0-r1.ebuild
new file mode 100644
index 000000000000..d47e578a5ab3
--- /dev/null
+++ b/dev-haskell/binary-orphans/binary-orphans-0.1.6.0-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+# ebuild generated by hackport 0.5.1.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Orphan instances for binary"
+HOMEPAGE="https://github.com/phadej/binary-orphans#readme"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/aeson-0.7.0.6:=[profile?] <dev-haskell/aeson-1.2:=[profile?]
+ >=dev-haskell/case-insensitive-1.2.0.4:=[profile?] <dev-haskell/case-insensitive-1.2.1:=[profile?]
+ >=dev-haskell/hashable-1.2.3.3:=[profile?] <dev-haskell/hashable-1.3:=[profile?]
+ >=dev-haskell/nats-1:=[profile?] <dev-haskell/nats-1.2:=[profile?]
+ >=dev-haskell/scientific-0.3.3.8:=[profile?] <dev-haskell/scientific-0.4:=[profile?]
+ >=dev-haskell/semigroups-0.16.2.2:=[profile?]
+ >=dev-haskell/tagged-0.7.3:=[profile?] <dev-haskell/tagged-0.8.6:=[profile?]
+ >=dev-haskell/text-1.2.0.6:=[profile?] <dev-haskell/text-1.3:=[profile?]
+ >=dev-haskell/text-binary-0.1.0:=[profile?] <dev-haskell/text-binary-0.3:=[profile?]
+ >=dev-haskell/unordered-containers-0.2.5.1:=[profile?] <dev-haskell/unordered-containers-0.3:=[profile?]
+ >=dev-haskell/vector-0.10.12.3:=[profile?] <dev-haskell/vector-0.13:=[profile?]
+ >=dev-haskell/vector-binary-instances-0.2.1.0:=[profile?] <dev-haskell/vector-binary-instances-0.3:=[profile?]
+ >=dev-haskell/void-0.7:=[profile?] <dev-haskell/void-0.8:=[profile?]
+ >=dev-lang/ghc-7.6.2:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.16.0
+ test? ( >=dev-haskell/quickcheck-2.7 <dev-haskell/quickcheck-2.9.3
+ >=dev-haskell/quickcheck-instances-0.3.11 <dev-haskell/quickcheck-instances-0.3.13
+ >=dev-haskell/tasty-0.10.1.2 <dev-haskell/tasty-0.12
+ >=dev-haskell/tasty-quickcheck-0.8.3.2 <dev-haskell/tasty-quickcheck-0.9 )
+"
+
+src_prepare() {
+ default
+
+ cabal_chdeps \
+ 'semigroups >=0.16.2.2 && <0.18.3' 'semigroups >=0.16.2.2'
+}
diff --git a/dev-haskell/binary-orphans/metadata.xml b/dev-haskell/binary-orphans/metadata.xml
new file mode 100644
index 000000000000..3b512c102ba0
--- /dev/null
+++ b/dev-haskell/binary-orphans/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>haskell@gentoo.org</email>
+ <name>Gentoo Haskell</name>
+ </maintainer>
+ <longdescription>
+ `binary-orphans` defines orphan instances for types in some popular packages.
+ </longdescription>
+</pkgmetadata>