summaryrefslogtreecommitdiff
path: root/dev-haskell/binary-instances
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /dev-haskell/binary-instances
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'dev-haskell/binary-instances')
-rw-r--r--dev-haskell/binary-instances/Manifest3
-rw-r--r--dev-haskell/binary-instances/binary-instances-1.0.0.1.ebuild50
-rw-r--r--dev-haskell/binary-instances/metadata.xml8
3 files changed, 61 insertions, 0 deletions
diff --git a/dev-haskell/binary-instances/Manifest b/dev-haskell/binary-instances/Manifest
new file mode 100644
index 000000000000..33724a6dab54
--- /dev/null
+++ b/dev-haskell/binary-instances/Manifest
@@ -0,0 +1,3 @@
+DIST binary-instances-1.0.0.1.tar.gz 5025 BLAKE2B 403f6bc8c55bec745b5284b8ebd1ddb429b277b1acbd9081207a40f07eefdc5533cf612fb74bbd7a741378051e06cb6d1d85413572e8e12a42e244e17a42649e SHA512 8933f2eab4a23460bd9be7547f229416adccb3e82ec452f75567fa5b5cb6babe4b7f243fbf3799099647bc4f890eaa1acc962128caa8caafc3ff724867585e3d
+EBUILD binary-instances-1.0.0.1.ebuild 2208 BLAKE2B 0d1d9f228b451ffeb05ea0628a2664bf3fad073e04e8c5d9081b43bc7c3a655dcbb448ac551640dfc861ea7da29be5ac96f0f312e072dafa58448e8b9b02cd85 SHA512 170d71fda641f588e353b917c175ed6d038c9b1df94ad092badf79cb3879f101743b8cfbba5ea7d311800e2e7acf19052d0d4d76e81e8e494d5db14fdb73afbb
+MISC metadata.xml 249 BLAKE2B 84b809c265ff2a09d1f06c66d4797652ff4c64205d94323e07333ae0fbddcfb8c58d0176a8cc52bd37e9353371d987b9b473b9747cb082e1c2871ed80fcfa144 SHA512 ce055b41ff1c10209e88579fe21ce16550be7e9b21f87724564f06430aa6f478974f186a10c8ff7e92398f534c09109aeed57eae1c6d2b56b5c99ebfb64a0015
diff --git a/dev-haskell/binary-instances/binary-instances-1.0.0.1.ebuild b/dev-haskell/binary-instances/binary-instances-1.0.0.1.ebuild
new file mode 100644
index 000000000000..14821193cb32
--- /dev/null
+++ b/dev-haskell/binary-instances/binary-instances-1.0.0.1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.6.4
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Orphan instances for binary"
+HOMEPAGE="https://github.com/phadej/binary-instances#readme"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RESTRICT=test # Needs fix in ghc/text: https://github.com/haskell/text/issues/277
+
+RDEPEND=">=dev-haskell/aeson-0.7.0.6:=[profile?] <dev-haskell/aeson-1.5:=[profile?]
+ >=dev-haskell/binary-orphans-1.0.1:=[profile?] <dev-haskell/binary-orphans-1.1:=[profile?]
+ >=dev-haskell/case-insensitive-1.2.0.4:=[profile?] <dev-haskell/case-insensitive-1.2.2:=[profile?]
+ >=dev-haskell/hashable-1.2.3.3:=[profile?] <dev-haskell/hashable-1.4:=[profile?]
+ >=dev-haskell/scientific-0.3.3.8:=[profile?] <dev-haskell/scientific-0.4:=[profile?]
+ >=dev-haskell/tagged-0.7.3:=[profile?] <dev-haskell/tagged-0.8.7:=[profile?]
+ >=dev-haskell/text-1.2.0.6:=[profile?] <dev-haskell/text-1.3:=[profile?]
+ >=dev-haskell/text-binary-0.2.1.1:=[profile?] <dev-haskell/text-binary-0.3:=[profile?]
+ >=dev-haskell/time-compat-1.9.2.2:=[profile?] <dev-haskell/time-compat-1.10:=[profile?]
+ >=dev-haskell/unordered-containers-0.2.5.1:=[profile?] <dev-haskell/unordered-containers-0.3:=[profile?]
+ >=dev-haskell/vector-0.10.12.3:=[profile?] <dev-haskell/vector-0.13:=[profile?]
+ >=dev-haskell/vector-binary-instances-0.2.1.0:=[profile?] <dev-haskell/vector-binary-instances-0.3:=[profile?]
+ >=dev-lang/ghc-7.6.2:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.16.0
+ test? ( >=dev-haskell/quickcheck-2.13.1 <dev-haskell/quickcheck-2.14
+ >=dev-haskell/quickcheck-instances-0.3.21 <dev-haskell/quickcheck-instances-0.4
+ >=dev-haskell/tasty-0.10.1.2 <dev-haskell/tasty-1.3
+ >=dev-haskell/tasty-quickcheck-0.8.3.2 <dev-haskell/tasty-quickcheck-0.11 )
+"
+
+src_prepare() {
+ default
+
+ cabal_chdeps \
+ 'base >=4.6.0.1 && <4.15' 'base >=4.6.0.1' && <5 \
+ 'binary >=0.5.1.1 && <0.8.9' 'binary >=0.5.1.1'
+}
diff --git a/dev-haskell/binary-instances/metadata.xml b/dev-haskell/binary-instances/metadata.xml
new file mode 100644
index 000000000000..b7878815d80d
--- /dev/null
+++ b/dev-haskell/binary-instances/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>haskell@gentoo.org</email>
+ <name>Gentoo Haskell</name>
+ </maintainer>
+</pkgmetadata>