summaryrefslogtreecommitdiff
path: root/dev-haskell/attoparsec/attoparsec-0.14.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-23 02:48:52 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-23 02:48:52 +0100
commitfd70f5e3ed54d5e013c11a3f3e632e80838171d0 (patch)
treec6bf0dac8239e644ccc09b184e4eb9cca9701dcf /dev-haskell/attoparsec/attoparsec-0.14.4.ebuild
parent5deadca7219297a3c1f90eca00544a00e33efdbc (diff)
gentoo auto-resync : 23:07:2022 - 02:48:51
Diffstat (limited to 'dev-haskell/attoparsec/attoparsec-0.14.4.ebuild')
-rw-r--r--dev-haskell/attoparsec/attoparsec-0.14.4.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-haskell/attoparsec/attoparsec-0.14.4.ebuild b/dev-haskell/attoparsec/attoparsec-0.14.4.ebuild
new file mode 100644
index 000000000000..bc2f7907a12f
--- /dev/null
+++ b/dev-haskell/attoparsec/attoparsec-0.14.4.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.7.1.1.9999
+#hackport: flags: -developer
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour" # Disable test-suite: circular depends
+inherit haskell-cabal
+RESTRICT=test # disabled at build time
+
+DESCRIPTION="Fast combinator parsing for bytestrings and text"
+HOMEPAGE="https://github.com/bgamari/attoparsec"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+
+RDEPEND=">=dev-haskell/scientific-0.3.1:=[profile?] <dev-haskell/scientific-0.4:=[profile?]
+ >=dev-lang/ghc-8.4.3:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-2.2.0.1"
+# test? ( >=dev-haskell/quickcheck-2.13.2 <dev-haskell/quickcheck-2.15
+# dev-haskell/quickcheck-unicode
+# >=dev-haskell/tasty-0.11
+# >=dev-haskell/tasty-quickcheck-0.8
+# dev-haskell/vector )
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=-developer
+}