summaryrefslogtreecommitdiff
path: root/dev-haskell/arithmoi/arithmoi-0.4.3.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-haskell/arithmoi/arithmoi-0.4.3.0.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-haskell/arithmoi/arithmoi-0.4.3.0.ebuild')
-rw-r--r--dev-haskell/arithmoi/arithmoi-0.4.3.0.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-haskell/arithmoi/arithmoi-0.4.3.0.ebuild b/dev-haskell/arithmoi/arithmoi-0.4.3.0.ebuild
new file mode 100644
index 000000000000..b6438c58fa74
--- /dev/null
+++ b/dev-haskell/arithmoi/arithmoi-0.4.3.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+# ebuild generated by hackport 0.5.9999
+#hackport: flags: -check-bounds
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Efficient basic number-theoretic functions. Primes, powers, integer logarithms"
+HOMEPAGE="https://github.com/cartazio/arithmoi"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/mtl-2.0:=[profile?] <dev-haskell/mtl-2.3:=[profile?]
+ >=dev-haskell/nats-1:=[profile?] <dev-haskell/nats-1.2:=[profile?]
+ >=dev-haskell/random-1.0:=[profile?] <dev-haskell/random-1.2:=[profile?]
+ >=dev-haskell/semigroups-0.8:=[profile?]
+ >=dev-lang/ghc-7.8.2:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.18.1.3
+ test? ( >=dev-haskell/quickcheck-2.7.6 <dev-haskell/quickcheck-2.10
+ >=dev-haskell/smallcheck-1.1 <dev-haskell/smallcheck-1.2
+ >=dev-haskell/tasty-0.10 <dev-haskell/tasty-0.12
+ >=dev-haskell/tasty-hunit-0.9 <dev-haskell/tasty-hunit-0.10
+ >=dev-haskell/tasty-quickcheck-0.8 <dev-haskell/tasty-quickcheck-0.9
+ >=dev-haskell/tasty-smallcheck-0.8 <dev-haskell/tasty-smallcheck-0.9
+ >=dev-haskell/transformers-compat-0.4 )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=-check-bounds
+}