summaryrefslogtreecommitdiff
path: root/dev-haskell/aeson-qq
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-haskell/aeson-qq
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-haskell/aeson-qq')
-rw-r--r--dev-haskell/aeson-qq/Manifest5
-rw-r--r--dev-haskell/aeson-qq/aeson-qq-0.7.4.ebuild30
-rw-r--r--dev-haskell/aeson-qq/aeson-qq-0.8.1.ebuild33
-rw-r--r--dev-haskell/aeson-qq/metadata.xml23
4 files changed, 91 insertions, 0 deletions
diff --git a/dev-haskell/aeson-qq/Manifest b/dev-haskell/aeson-qq/Manifest
new file mode 100644
index 000000000000..7560b12fedaf
--- /dev/null
+++ b/dev-haskell/aeson-qq/Manifest
@@ -0,0 +1,5 @@
+DIST aeson-qq-0.7.4.tar.gz 4202 BLAKE2B adf425ea18b06658aaa509693a65a80d8bac4aa46013e9d30de9b8e46772239ab18ccb975207c95b773e2253722a347c36ed5417a112c751f91a1b92ee8b8464 SHA512 4ca302f27d03698d661bf04c8fa2cfb2d725988e694f62bddfd0ae544e64c6b4980b796cf4b85e13fd9ae289922b242e649abc71df2588306cd024d38e7d90fb
+DIST aeson-qq-0.8.1.tar.gz 4286 BLAKE2B 1b1e66d5a9c3f67f43b46665f246c1e83ffdcb92193be69614d49a8236f54b9ad97ca2304bb7e7100c246e682e68cf6ec81ebe3c3fcb1e8019986507a8a45630 SHA512 b1c697c60b7ec721f7801f5ff242ddceaa19a9ada257e7c6b3d3ef502163c058a50bed1110f8fbf761fa8f3da79abec33a04edb2b6555b0d6cf9a0710ad0302d
+EBUILD aeson-qq-0.7.4.ebuild 753 BLAKE2B 74d6b30392c3c3a591f3fadd1974b1780fd593592df52c96b4b8849718e1cdc598f77aecff337040ccb6c9efdf5dffc7f36f718d7244df737c353b07100055e5 SHA512 cd1d9ca242f383f3d1ce4dce411cbcee176f7e311dde02f68531cda7bfb09facccead34fee185aaa997f49afe5c7654e896913eca954a1a879c34da72712f2fe
+EBUILD aeson-qq-0.8.1.ebuild 864 BLAKE2B 3e8f878675ccbac75a0f582d8398d50bbabd0be803373a693573c6642b9316e62b92a6a163392ffffe99713b36eee3c7a06aa15f2ab8e0e82c3ce5a424a9131d SHA512 ae48792e929d0e9147fcc6242b50b7913c6c653fdac6fe9d6f7d9028f5df180bc7ac172c4d0b265ff60aa49bb3512e5160c29234ac5a88e7f26d8d965dd8ce2b
+MISC metadata.xml 727 BLAKE2B fb4fc94b0cc95d9e0a31529f45dfaab83c09c0d81ae64f0334e40054c12cfcacb93fbf8293eb2b99722c32b63bf66ebde6119af30af45b4a40212a462c42b935 SHA512 a8ad3155394526f744fa3a5aac2940a93817d5c8237d57ccb393afb3077a5c135bffb8ebee3f2208e20968e47c6f861deb24c9d46e6f75f887ec94dd311ba0f5
diff --git a/dev-haskell/aeson-qq/aeson-qq-0.7.4.ebuild b/dev-haskell/aeson-qq/aeson-qq-0.7.4.ebuild
new file mode 100644
index 000000000000..e2f11d086e5d
--- /dev/null
+++ b/dev-haskell/aeson-qq/aeson-qq-0.7.4.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.4.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="JSON quasiquoter for Haskell"
+HOMEPAGE="https://github.com/zalora/aeson-qq"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/aeson-0.6:=[profile?]
+ >=dev-haskell/haskell-src-meta-0.1.0:=[profile?]
+ dev-haskell/parsec:=[profile?]
+ dev-haskell/text:=[profile?]
+ dev-haskell/vector:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( dev-haskell/hspec )
+"
diff --git a/dev-haskell/aeson-qq/aeson-qq-0.8.1.ebuild b/dev-haskell/aeson-qq/aeson-qq-0.8.1.ebuild
new file mode 100644
index 000000000000..1f3a0e44a09f
--- /dev/null
+++ b/dev-haskell/aeson-qq/aeson-qq-0.8.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.6.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="JSON quasiquoter for Haskell"
+HOMEPAGE="https://github.com/zalora/aeson-qq"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/aeson-0.6:=[profile?]
+ dev-haskell/attoparsec:=[profile?]
+ dev-haskell/base-compat:=[profile?]
+ >=dev-haskell/haskell-src-meta-0.1.0:=[profile?]
+ dev-haskell/parsec:=[profile?]
+ dev-haskell/scientific:=[profile?]
+ dev-haskell/text:=[profile?]
+ dev-haskell/vector:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( dev-haskell/hspec )
+"
diff --git a/dev-haskell/aeson-qq/metadata.xml b/dev-haskell/aeson-qq/metadata.xml
new file mode 100644
index 000000000000..93baffe1b288
--- /dev/null
+++ b/dev-haskell/aeson-qq/metadata.xml
@@ -0,0 +1,23 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>haskell@gentoo.org</email>
+ <name>Gentoo Haskell</name>
+ </maintainer>
+ <longdescription>
+ @aeson-qq@ provides a JSON quasiquoter for Haskell.
+
+ This package exposes the function `aesonQQ` that compile-time
+ converts a string representation of a JSON value into a
+ `Data.Aeson.Value`. `aesonQQ` has the signature
+
+ &gt;aesonQQ :: QuasiQuoter
+
+ Consult the @README@ for documentation:
+ &lt;https://github.com/zalora/aeson-qq#readme&gt;
+ </longdescription>
+ <upstream>
+ <remote-id type="github">zalora/aeson-qq</remote-id>
+ </upstream>
+</pkgmetadata>