summaryrefslogtreecommitdiff
path: root/dev-haskell/aeson-pretty/aeson-pretty-0.8.10.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-23 08:35:49 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-23 08:35:49 +0100
commit386855c4d1ef509c1fd32abd721589c81669613b (patch)
tree35dc984118f0a7dc2df88313d83bb5779fd12514 /dev-haskell/aeson-pretty/aeson-pretty-0.8.10.ebuild
parent0118ac4510d7b85ca62da20e4abd1286dd8bd752 (diff)
gentoo auto-resync : 23:10:2023 - 08:35:49
Diffstat (limited to 'dev-haskell/aeson-pretty/aeson-pretty-0.8.10.ebuild')
-rw-r--r--dev-haskell/aeson-pretty/aeson-pretty-0.8.10.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-haskell/aeson-pretty/aeson-pretty-0.8.10.ebuild b/dev-haskell/aeson-pretty/aeson-pretty-0.8.10.ebuild
new file mode 100644
index 000000000000..4e095248d035
--- /dev/null
+++ b/dev-haskell/aeson-pretty/aeson-pretty-0.8.10.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.8.4.0.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="JSON pretty-printing library and command-line tool"
+HOMEPAGE="https://github.com/informatikr/aeson-pretty"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+IUSE="+executable"
+
+RDEPEND=">=dev-haskell/base-compat-0.9:=[profile?]
+ >=dev-haskell/scientific-0.3:=[profile?]
+ >=dev-haskell/text-0.11:=[profile?]
+ >=dev-haskell/unordered-containers-0.2.14.0:=[profile?]
+ >=dev-haskell/vector-0.9:=[profile?]
+ >=dev-lang/ghc-8.8.1:=
+ >=dev-haskell/aeson-1.1:=[profile?] <dev-haskell/aeson-2.3:=[profile?]
+ executable? ( >=dev-haskell/aeson-0.6:=[profile?]
+ >=dev-haskell/attoparsec-0.10:=[profile?]
+ dev-haskell/attoparsec-aeson:=[profile?]
+ >=dev-haskell/cmdargs-0.7:=[profile?] )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-3.0.0.0
+"
+
+src_configure() {
+ if use executable; then
+ local lib_flag=-lib-only
+ else
+ local lib_flag=lib-only
+ fi
+
+ haskell-cabal_src_configure \
+ --flag="${lib_flag}"
+}