summaryrefslogtreecommitdiff
path: root/dev-haskell/adjunctions/adjunctions-4.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /dev-haskell/adjunctions/adjunctions-4.4.ebuild
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'dev-haskell/adjunctions/adjunctions-4.4.ebuild')
-rw-r--r--dev-haskell/adjunctions/adjunctions-4.4.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-haskell/adjunctions/adjunctions-4.4.ebuild b/dev-haskell/adjunctions/adjunctions-4.4.ebuild
new file mode 100644
index 000000000000..fb56b2288d83
--- /dev/null
+++ b/dev-haskell/adjunctions/adjunctions-4.4.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+# ebuild generated by hackport 0.5.4.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Adjunctions and representable functors"
+HOMEPAGE="https://github.com/ekmett/adjunctions/"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/comonad-4:=[profile?] <dev-haskell/comonad-6:=[profile?]
+ >=dev-haskell/contravariant-1:=[profile?] <dev-haskell/contravariant-2:=[profile?]
+ >=dev-haskell/distributive-0.5.1:=[profile?] <dev-haskell/distributive-1:=[profile?]
+ >=dev-haskell/free-4:=[profile?] <dev-haskell/free-6:=[profile?]
+ >=dev-haskell/mtl-2.0.1:=[profile?] <dev-haskell/mtl-2.3:=[profile?]
+ >=dev-haskell/profunctors-4:=[profile?] <dev-haskell/profunctors-6:=[profile?]
+ >=dev-haskell/semigroupoids-4:=[profile?] <dev-haskell/semigroupoids-6:=[profile?]
+ >=dev-haskell/semigroups-0.11:=[profile?] <dev-haskell/semigroups-1:=[profile?]
+ >=dev-haskell/tagged-0.7:=[profile?] <dev-haskell/tagged-1:=[profile?]
+ >=dev-haskell/transformers-compat-0.3:=[profile?] <dev-haskell/transformers-compat-1:=[profile?]
+ >=dev-haskell/void-0.5.5.1:=[profile?] <dev-haskell/void-1:=[profile?]
+ >=dev-lang/ghc-7.8.2:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.18.1.3
+ test? ( >=dev-haskell/generic-deriving-1.11 <dev-haskell/generic-deriving-2
+ >=dev-haskell/hspec-2 <dev-haskell/hspec-3 )
+"
+
+src_prepare() {
+ default
+
+ cabal_chdeps \
+ 'containers >= 0.3 && < 0.6' 'containers >= 0.3'
+}