summaryrefslogtreecommitdiff
path: root/dev-go/zglob
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-02-11 16:09:52 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-02-11 16:09:52 +0000
commitf78108598211053d41752a83e0345441bb9014ae (patch)
treedd2fc7ae0a1aea7bda4942ab0c453d1e55284b37 /dev-go/zglob
parentdc45b83b28fb83e9659492066e347b8dc60bc9e3 (diff)
gentoo resync : 11.02.2018
Diffstat (limited to 'dev-go/zglob')
-rw-r--r--dev-go/zglob/Manifest3
-rw-r--r--dev-go/zglob/metadata.xml12
-rw-r--r--dev-go/zglob/zglob-0_p20171230.ebuild35
3 files changed, 50 insertions, 0 deletions
diff --git a/dev-go/zglob/Manifest b/dev-go/zglob/Manifest
new file mode 100644
index 000000000000..8f6fe0adf685
--- /dev/null
+++ b/dev-go/zglob/Manifest
@@ -0,0 +1,3 @@
+DIST zglob-0_p20171230.tar.gz 7993 BLAKE2B dd441531a30f6491c5c85b82e364bf8a21adb9d3842793ef2d9afc617ab5a7b7f6d83e53bb911bfe0a8205f5a434aaee42f2ab7160cce103f0e83cc198757fa7 SHA512 6eec0222ee27527b992809f235b6e06d24e857866f969f25901eaf21c9a352d6f50ec3ef2874d51cc7b91015bc9c6f197e79445e2c36ed1facad4ec04e919d83
+EBUILD zglob-0_p20171230.ebuild 776 BLAKE2B 628f0976fa333af0b4fa24f60c5936ea6fa8bbca6b5be5e42b88d10b68793ae39daa1161832c28c843a24289fd94ac73d18f52a978b2f825b60337404359b464 SHA512 ad66e99f8e227416d2056476be79942a58ea1a4805cc64fd96f379c594968a237401cb992a4f856bcfdc8e2592ce62003989bc1ad38466f3e477697175f3b9b3
+MISC metadata.xml 363 BLAKE2B 8aa3ed7df03a148ce1d425366aedf96f517c8c8580e03df2040e870130fc77367a1cb67b4b93356f20931288e03d76913642cf0688154b4ba4b7af7cf44a6a7b SHA512 66b9bcae2be1aa69dda2374f2c4c4c02d6c1194dcd7750573323b66d6f266a52ed738a89091582864eaa0a0a494bc6e4a16c5d30008c65634cb9c8a368d917a2
diff --git a/dev-go/zglob/metadata.xml b/dev-go/zglob/metadata.xml
new file mode 100644
index 000000000000..004ae50f4a5f
--- /dev/null
+++ b/dev-go/zglob/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person" >
+ <email>lluixhi@gmail.com</email>
+ <name>Aric Belsito</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-go/zglob/zglob-0_p20171230.ebuild b/dev-go/zglob/zglob-0_p20171230.ebuild
new file mode 100644
index 000000000000..2d0bf65d5587
--- /dev/null
+++ b/dev-go/zglob/zglob-0_p20171230.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+EGO_PN=github.com/mattn/go-zglob
+
+if [[ ${PV} = *9999* ]]; then
+ inherit golang-vcs
+else
+ KEYWORDS="~amd64"
+ EGIT_COMMIT=4959821b481786922ac53e7ef25c61ae19fb7c36
+ SRC_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+ inherit golang-vcs-snapshot
+fi
+inherit golang-build
+
+DESCRIPTION="Unix-optimized file globbing and directory walking for Go"
+HOMEPAGE="https://github.com/mattn/go-zglob"
+LICENSE="MIT"
+SLOT="0/${PVR}"
+RDEPEND=""
+
+src_compile() {
+ EGO_PN="${EGO_PN}/cmd/zglob" golang-build_src_compile
+}
+
+src_install() {
+ dobin zglob
+
+ golang-build_src_install
+
+ pushd "src/${EGO_PN}" >/dev/null || die
+ einstalldocs
+ popd >/dev/null || die
+}