summaryrefslogtreecommitdiff
path: root/dev-go/vend/vend-1.0.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /dev-go/vend/vend-1.0.3.ebuild
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'dev-go/vend/vend-1.0.3.ebuild')
-rw-r--r--dev-go/vend/vend-1.0.3.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-go/vend/vend-1.0.3.ebuild b/dev-go/vend/vend-1.0.3.ebuild
new file mode 100644
index 000000000000..5259d421f849
--- /dev/null
+++ b/dev-go/vend/vend-1.0.3.ebuild
@@ -0,0 +1,21 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit go-module
+
+DESCRIPTION="dependency vendor for Go programs"
+HOMEPAGE="https://github.com/nomad-software/vend"
+SRC_URI="https://github.com/nomad-software/vend/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+src_compile() {
+ ego build .
+}
+
+src_install() {
+ dobin vend
+ einstalldocs
+}