summaryrefslogtreecommitdiff
path: root/dev-go/gom/gom-0_pre20151110.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-go/gom/gom-0_pre20151110.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-go/gom/gom-0_pre20151110.ebuild')
-rw-r--r--dev-go/gom/gom-0_pre20151110.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-go/gom/gom-0_pre20151110.ebuild b/dev-go/gom/gom-0_pre20151110.ebuild
new file mode 100644
index 000000000000..c895ff693699
--- /dev/null
+++ b/dev-go/gom/gom-0_pre20151110.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+EGO_PN=github.com/mattn/gom
+
+if [[ ${PV} = *9999* ]]; then
+ inherit golang-vcs
+else
+ EGIT_COMMIT=c522e7d
+ ARCHIVE_URI="https://github.com/mattn/gom/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+ inherit golang-vcs-snapshot
+fi
+inherit golang-build
+
+DESCRIPTION="Go Dependency management system similar to bundle for ruby"
+HOMEPAGE="https://github.com/mattn/gom"
+SRC_URI="${ARCHIVE_URI}"
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+DEPEND="dev-go/go-colortext:="
+RDEPEND=""
+
+src_install() {
+dobin gom
+dodoc src/${EGO_PN}/README.mkd
+}