summaryrefslogtreecommitdiff
path: root/dev-go/golint/golint-0_pre20161114.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-go/golint/golint-0_pre20161114.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-go/golint/golint-0_pre20161114.ebuild')
-rw-r--r--dev-go/golint/golint-0_pre20161114.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-go/golint/golint-0_pre20161114.ebuild b/dev-go/golint/golint-0_pre20161114.ebuild
new file mode 100644
index 000000000000..5fffe12876dd
--- /dev/null
+++ b/dev-go/golint/golint-0_pre20161114.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+EGO_PN="github.com/golang/lint/..."
+
+if [[ ${PV} = *9999* ]]; then
+ inherit golang-vcs
+else
+ EGIT_COMMIT=206c0f0
+ SRC_URI="https://github.com/golang/lint/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+ inherit golang-vcs-snapshot
+fi
+inherit golang-build
+
+DESCRIPTION="a linter for Go"
+HOMEPAGE="https://godoc.org/golang.org/x/tools"
+LICENSE="BSD"
+SLOT="0/${PVR}"
+IUSE=""
+DEPEND=">=dev-lang/go-1.6
+ dev-go/go-tools"
+RDEPEND="!<dev-lang/go-1.6
+ dev-go/go-tools:="
+
+DOCS=(
+ src/github.com/golang/lint/CONTRIBUTING.md
+ src/github.com/golang/lint/README.md
+ src/github.com/golang/lint/misc
+ )
+
+ src_install() {
+ golang-build_src_install
+ einstalldocs
+ dobin bin/*
+}