summaryrefslogtreecommitdiff
path: root/dev-go/go-tour
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-03-19 11:37:34 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-03-19 11:37:34 +0000
commitb7b97785ebbb2f11d24d14dab8b81ed274f4ce6a (patch)
tree9fd110f9fc996e8a4213eeda994a8c112491b86d /dev-go/go-tour
parent066d27181e9a797ad9f8fc43b49fc9a10ff2f707 (diff)
gentoo resync : 19.03.2019
Diffstat (limited to 'dev-go/go-tour')
-rw-r--r--dev-go/go-tour/Manifest2
-rw-r--r--dev-go/go-tour/go-tour-0_p20180810.ebuild9
2 files changed, 8 insertions, 3 deletions
diff --git a/dev-go/go-tour/Manifest b/dev-go/go-tour/Manifest
index 3bc1564e6ed8..cf57581fc627 100644
--- a/dev-go/go-tour/Manifest
+++ b/dev-go/go-tour/Manifest
@@ -1,3 +1,3 @@
DIST go-tour-0_p20180810.tar.gz 319048 BLAKE2B 43c4ca53d939cf7590c8e3607e2089974f1b40dc9268ccbf9100e36d258d76a828c5512e662f20d125c07d0a35d48d3004c8f06d6f80a6a1645099d4ca592c57 SHA512 73eb1b7a228d046d572b2c781cdd7b43ef57de982987ab5808cbb2775c34c9805fac3c52fd68edd34ccadec5169ce5d61234eee553daf0b9ef2d2529e2817b44
-EBUILD go-tour-0_p20180810.ebuild 1094 BLAKE2B 2cbb46860460043328b8db825da7855d99105b109749cb94e6c79d6282d7a74b761db19ba3bca622da654a23d54bdf24b9e770d5b212c90c978bda2cc32b319d SHA512 43818de5961041d32b8227c561cbe7c7e5b93b13006580979e1c90d3d2d60d82cbeb280b41a6e481c0fc60183b66e0e18bb2866a70d81f542f4514f93f96f905
+EBUILD go-tour-0_p20180810.ebuild 1412 BLAKE2B 19c7e43de92c5a852e5516ff83bfbfc1e1f34adffd3d67094e38e9e602f273dc72f897db547dfd9c3d8b853d33aae1018bd0f2a64c39ed932bd9bfc369aeb2c4 SHA512 dbfa7d6c2151374cff74bc6623d8253042797c5429d5e2b039d896db0b06348ecb8f6940758b94e815cc45e62741d86c16e9f14511b3fef1290a65cefb6d9ae8
MISC metadata.xml 302 BLAKE2B b47fb7e4329ee56fd11c666f3493a1ad78c816390b7f1748c6bccb780aaf2440fc18f6d75352f80c481b40bdd9a060c192ed2fd1d6076bedf45aa57d67c6a2f0 SHA512 c49a4e57f4cc812eb4412bd71b02ac70785afd6d1793b09212f15a72a83d92a5c5f769ac569b7fe1e9f31b49b5abae913c647c75e82c3e7c3405e20819ff3b37
diff --git a/dev-go/go-tour/go-tour-0_p20180810.ebuild b/dev-go/go-tour/go-tour-0_p20180810.ebuild
index 0266d4dd62b2..c5967f041fa4 100644
--- a/dev-go/go-tour/go-tour-0_p20180810.ebuild
+++ b/dev-go/go-tour/go-tour-0_p20180810.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -20,11 +20,16 @@ DEPEND="dev-go/go-net:=
src_compile() {
local x
+ # Create a temporary GOROOT, since otherwise the executable is not
+ # built if it happens to be installed already.
+ cp -rs "$(go env GOROOT)" "${T}/goroot" || die
+ rm -rf "${T}/goroot/"{pkg/tool/$(go env GOOS)_$(go env GOARCH)/tour,src/${EGO_PN%/...}} || die
mkdir -p "${T}/golibdir/src/golang.org/x" || die
for x in net tools; do
ln -s "$(get_golibdir_gopath)/src/golang.org/x/${x}" "${T}/golibdir/src/golang.org/x/${x}" || die
done
- GOPATH="${S}:${T}/golibdir" GOBIN="${S}/bin" \
+ export -n GOCACHE XDG_CACHE_HOME #567192
+ GOPATH="${S}:${T}/golibdir" GOBIN="${S}/bin" GOROOT=${T}/goroot \
go install -v -work -x ${EGO_BUILD_FLAGS} "${EGO_PN}"
[[ -x bin/gotour ]] || die "gotour not found"
}