summaryrefslogtreecommitdiff
path: root/dev-go/go-tour/go-tour-0_p20180810.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
commit7bc9c63c9da678a7e6fceb095d56c634afd22c56 (patch)
tree4a67d50a439e9af63947e5f8b6ba3719af98b6c9 /dev-go/go-tour/go-tour-0_p20180810.ebuild
parentb284a3168fa91a038925d2ecf5e4791011ea5e7d (diff)
gentoo resync : 15.12.2019
Diffstat (limited to 'dev-go/go-tour/go-tour-0_p20180810.ebuild')
-rw-r--r--dev-go/go-tour/go-tour-0_p20180810.ebuild47
1 files changed, 0 insertions, 47 deletions
diff --git a/dev-go/go-tour/go-tour-0_p20180810.ebuild b/dev-go/go-tour/go-tour-0_p20180810.ebuild
deleted file mode 100644
index 331a91b1bb01..000000000000
--- a/dev-go/go-tour/go-tour-0_p20180810.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-EGO_PN="golang.org/x/tour/..."
-
-EGIT_COMMIT="d642b9371986f5bb2152547a0d525a57f634c3ef"
-ARCHIVE_URI="https://github.com/golang/tour/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
-KEYWORDS="~amd64"
-inherit golang-vcs-snapshot golang-build
-
-DESCRIPTION="A Tour of Go"
-HOMEPAGE="https://tour.golang.org"
-SRC_URI="${ARCHIVE_URI}"
-LICENSE="BSD MIT"
-SLOT="0"
-IUSE=""
-DEPEND="dev-go/go-net:=
- dev-go/go-tools:="
-
-src_compile() {
- local x
- # Create a temporary GOROOT, since otherwise the executable is not
- # built if it happens to be installed already.
- cp -rs "$(go env GOROOT)" "${T}/goroot" || die
- rm -rf "${T}/goroot/"{pkg/tool/$(go env GOOS)_$(go env GOARCH)/tour,src/${EGO_PN%/...}} || die
- mkdir -p "${T}/golibdir/src/golang.org/x" || die
- for x in net tools; do
- ln -s "$(get_golibdir_gopath)/src/golang.org/x/${x}" "${T}/golibdir/src/golang.org/x/${x}" || die
- done
- export -n GOCACHE XDG_CACHE_HOME #567192
- GOPATH="${S}:${T}/golibdir" GOBIN="${S}/bin" GOROOT=${T}/goroot \
- go install -v -work -x ${EGO_BUILD_FLAGS} "${EGO_PN}"
- [[ -x bin/gotour ]] || die "gotour not found"
-}
-
-src_install() {
- exeinto "$(go env GOTOOLDIR)"
- newexe bin/gotour tour
- insinto "$(go env GOROOT)"
- doins -r src
-}
-
-src_test() {
- GOPATH="${S}:${T}/golibdir" GOBIN="${S}/bin" \
- go test -v -work -x "${EGO_PN}" || die
-}