summaryrefslogtreecommitdiff
path: root/dev-go/go-text/go-text-0_pre20150806.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
commit1798c4aeca70ac8d0a243684d6a798fbc65735f8 (patch)
treee48e19cb6fa03de18e1c63e1a93371b7ebc4eb56 /dev-go/go-text/go-text-0_pre20150806.ebuild
parentd87262dd706fec50cd150aab3e93883b6337466d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-go/go-text/go-text-0_pre20150806.ebuild')
-rw-r--r--dev-go/go-text/go-text-0_pre20150806.ebuild49
1 files changed, 0 insertions, 49 deletions
diff --git a/dev-go/go-text/go-text-0_pre20150806.ebuild b/dev-go/go-text/go-text-0_pre20150806.ebuild
deleted file mode 100644
index 3fb9794a126a..000000000000
--- a/dev-go/go-text/go-text-0_pre20150806.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-EGO_PN=golang.org/x/text/...
-EGO_SRC=golang.org/x/text
-
-if [[ ${PV} = *9999* ]]; then
- inherit golang-vcs
-else
- KEYWORDS="~amd64"
- EGIT_COMMIT="1309a1875a4368c12688b9383c6bcac738c17c29"
- SRC_URI="https://github.com/golang/text/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
- inherit golang-vcs-snapshot
-fi
-inherit golang-build
-
-DESCRIPTION="Go text processing support"
-HOMEPAGE="https://godoc.org/golang.org/x/text"
-LICENSE="BSD"
-SLOT="0/${PVR}"
-IUSE=""
-DEPEND=""
-RDEPEND=""
-
-src_compile() {
- # Create a writable GOROOT in order to avoid sandbox violations.
- cp -sR "$(go env GOROOT)" "${T}/goroot" || die
- rm -rf "${T}/goroot/src/${EGO_SRC}" || die
- rm -rf "${T}/goroot/pkg/$(go env GOOS)_$(go env GOARCH)/${EGO_SRC}" || die
- export GOROOT="${T}/goroot"
- golang-build_src_compile
-}
-
-src_test() {
- # Create go symlink for TestLinking in display/dict_test.go
- mkdir -p "${GOROOT}/bin"
- ln -s /usr/bin/go "${GOROOT}/bin/go" || die
- golang-build_src_test
-}
-
-src_install() {
- golang-build_src_install
- export -n GOROOT
- exeopts -m0755 -p # preserve timestamps for bug 551486
- exeinto "$(go env GOROOT)/bin"
- doexe bin/*
-}